DHCP on an old, slow AIX box.

Jeff Sumner jeff.sumner at nationalcity.com
Tue Mar 18 06:19:05 UTC 2008

Here's my once/year request:

Anyone running DHCPD on a really slow AIX box experiencing problems? Version
3.1.0 and 3.1.1b1 both do the same thing. I've a teeny network (build for
experimentation) and have an old RS/6000 with BIND 9.4.2 (DDNS enabled) on
it, sufficient RAM, 10/100MB Ethernet adapter. DHCP builds fine (gcc
obtained from IBM- version 4.0.0) and seemingly runs well.

All DHCP requests are recorded in the log, dutifully, as are the offers.

Only once has a device obtained a lease. I almost never see packets coming
back into the devices. I've a couple Macs on the wire (with Wireshark) and I
get nothing back when trying to force DHCP requests- but the log does say
it's trying. 
I've even tried plugging right into the RS/6000. I've tried the other NIC on
the RS/6000, too, finding an old Ethernet transceiver.
Once, though, I got a DDNS entry to go, and the laptop did record a 15
minute lease, only to NOT be able to refresh it for failure to see the ack.

This device works fine as a DNS server, SSH server/client, or anything else
I could ask for. I don't see errors in the log, and netstat show nothing


***National City made the following annotations
This communication is a confidential and proprietary business communication.  
It is intended solely for the use of the designated recipient(s).  If this
communication is received in error, please contact the sender and delete 
this communication.

More information about the dhcp-users mailing list