dhcpd-4.1.0 DLPI Solaris info

Glenn Satchell Glenn.Satchell at uniq.com.au
Mon Nov 16 04:11:12 UTC 2009


This is fixed in 4.1.1b1


>Date: Sun, 15 Nov 2009 22:11:10 -0500
>From: Frank Cusack <fcusack at fcusack.com>
>To: dhcp-users at lists.isc.org
>Subject: dhcpd-4.1.0 DLPI Solaris info
>The README for dhcp-4.1.0 has a little bit of info for a Solaris dhcpd
>using DLPI problem.  I have some more data to share.
>I am using Solaris 10 U8 (10/09) x86.  If I run dhcpd in a zone (using
>exclusive IP) then it seems to work fine. If I run it in the global zone,
>dhcpd does receive a first packet (DISCOVER in this case; didn't test
>REQUEST) and thinks it is sending a reply, however the reply does not
>make it onto the wire, as observed by a tcpdump running on the same host.
>After the first packet, dhcpd stops receiving requests.
>I don't recall exactly but I think that dhcpd always receives the first
>packet after it is restarted, regardless of whether or not tcpdump was
>I'm happy to test any proposed fix, however you will have to email me
>directly as I am now unsubscribing from the list.
>dhcp-users mailing list
>dhcp-users at lists.isc.org

More information about the dhcp-users mailing list