dhcpserver and dhcperf on same machine - still not working

Rajitha Chinnapu rajithachinnapu at yahoo.com
Wed Aug 11 21:16:27 UTC 2010


I installed dhcperf on red hat linux. Here is what i see when i run dhcperf.

/usr/local/nom/bin$ sudo ./dhcperf --server opah --one-discover

No response after 4 seconds: failed to acquire address.

/usr/local/nom/bin$ sudo ./dhcperf --server opah --discover --clients 20  
Beginning DHCPDISCOVER load test.
Initial probe complete: High-water mark is 1 clients/second.
0 four-way handshakes per second.

And then, to account for the drawback in the following post in the groups, i 
installed dhcperf on the same machine that has the dhcp server. but still, it 
gives the same problem. That means, something else is wrong here. any help is 


dhcperf works really well.  It allows you to test DHCPDISCOVER tps as 
well as RENEW tps.  It starts with 30 clients/sec and then keep working 
its way up.  The one downfall is that it is extremely picky about when 
it needs to receive a response from the server.  I believe it needs to 
receive a response within .1 seconds, if it doesn't it considers that a 
failure.  This is not a real world test by any means, as clients will 
retransmit their requests.  dhcperf does not take this into account. 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20100811/41ef3c5a/attachment.html>

More information about the dhcp-users mailing list