Nicholas F Miller nicholas.miller at Colorado.EDU
Wed Sep 7 16:07:32 UTC 2011

I am sure there are no settings set on the client. I built the test clients from scratch.

I wonder if this is a know issue and this is the workaround:

DHCP 4.2.2


New Features

- Strict checks for content of domain-name DHCPv4 option can now be   configured during compilation time. Even though RFC2132 does not allow to store more than one domain in domain-name option, such behavior is now enabled by default, but this may change some time in the future.  See ACCEPT_LIST_IN_DOMAIN_NAME define in includes/site.h.  [ISC-Bugs #24167]
Nicholas Miller, ITS, University of Colorado at Boulder

On Sep 7, 2011, at 9:51 AM, Tom Schmitt wrote:

>> We have been testing domain-search and are having some issues. Do Windows
>> machines support domain-search. From our testing it looks like only *nix
>> machines support this option. When we use domain-search the Windows machines
>> do not get any DNS suffix. Macs and *unix work fine. We have tried it
>> globally and per subnet. The only thing that works for Windows machines it
>> domain-name.
> I already saw Windows clients where it worked, so it has to be possible :-)
> I also made the experience that on most Windows clients it doesn't work. But at least these clients I checked had always somewhere local entries for the searchlist and therefore ignoring the data from DHCP.
> Are you sure there is no local config for search suffixe on your windows clients?
> -- 
> Empfehlen Sie GMX DSL Ihren Freunden und Bekannten und wir
> belohnen Sie mit bis zu 50,- Euro!
> _______________________________________________
> dhcp-users mailing list
> dhcp-users at

More information about the dhcp-users mailing list