dhcpd -6: buffer overflow detected

Fred Zwarts (KVI) F.Zwarts at KVI.nl
Fri Mar 30 10:21:06 UTC 2012

We are using the ISC dhcpd server for both IPv4 and IPv6 for more than a 
year now. Up to recently, the Suse distribution included only version 3 of 
isc dhcp, so, in order to run in IPv6 mode, we downloaded the isc dhcp 
source code and built the server ourselves.
We worked around a few problems for IPv6 and finally the dhcpd-4.2.1-P1 
version was running in a stable mode for many months now on a Suse Linux 
Enterprise System 11 SP1 x86_64 system, both for IPv4 and IPv6.
Yesterday, we installed Service Pack 2 for SLES11, which now contains isc 
dhcpd 4.2.3-P2.
In IPv4 mode, it was no problem to run the new dhcpd server with exactly the 
same configuration as before.
However, in IPv6 mode the dhcpd server runs for something like one minute 
and then stops. In the syslog we find the message:

Mar 29 13:30:10 SRV014 dhcpd: *** buffer overflow detected ***: 
/usr/sbin/dhcpd6 terminated

We have tried several time to run the dhcpd server, but each time it crashes 
in the same way after about one minute. This happens also when the server 
runs in foreground mode.

Fortunately, we still  have the executable of the 4.2.1-P1, so we changed 
the soft link /usr/sbin/dhcpd6 to point to this old image. Now the server 
does not crash anymore.

We don't know how exactly the 4.2.3-P2 version was built by Suse. So we are 
not sure whether this problem is caused by the way the source code was 
compiled, or by a change introduce between the releases of these two 
Also we don't know whether there is a specific part in our configuration, or 
a specific packet sent by a client that triggers the crash.
So, my question is whether someone else uses 4.2.3-P2 in IPv6 mode without 
Also suggestions for diagnosing the problem further are welcome.


More information about the dhcp-users mailing list