Intermittent problems with DHCP Offers

Joseph Bernard jhb at
Tue Apr 29 03:35:52 UTC 2014

We are running a VM with CentOS5 and dhcpd 3.0.5 on ESXi.  About six weeks ago, we had our server start not responding to traffic correctly.  It seemed that the dhcpd service was fine but a noticeable amount of network traffic was not making its way to and from the server correctly.  We rebooted the VM, but that didn't fix it.  We moved the VM's connection to a different vSwitch and that fixed it.  A week later, the VM had issues again.  It was similar but not exactly the same behavior.  We tried the different vSwitch trick, but that didn't work and made it start acting like it did the week before.  We ended up rebooting the entire ESXi server and the problem was fixed.  The problem came back a third time a week later.  A reboot of the ESXi server fixed the problem again.  At that point we moved the VM to a completely different ESXi box.  We watched it like hawks that fourth week, but it didn't go down.  The original host was running ESXi 4.1 and the new one is running 5.0.  The VM has been running without issue for the last 2 weeks.  Before this all happened, the ESXi box had been up over 1000 days and the VM over 900 days.

We never did figure out what the problem was.  There were so many guesses but we couldn't nail anything down.  The amount of the traffic was not abnormal.  Our only guess is maybe some kind of malformed traffic was being sent.  We thought of leaving it on the old box and let it happen a 4th time without making anything changes, but we needed things to work.  Unfortunately, we may never know what caused it.

Joseph B.

On Apr 28, 2014, at 8:37 PM, Scott Lacy <scott at>

> Running 4.1.1-p1 on a physical RHEL6 system, I've had an intermittent issue recently with dhcp offers not being responded to.  This started late last week, and was first resolved by rebooting the system; restarting dhcpd nor disabling iptables resolved the problem.  Informs and Acks seemed to work fine, but releasing and renewing did not work.
> The problem popped back up again today, and reboots did not resolve the problem; I wound up creating a VM with CentOS5 and dhcpd 3.0.5 on a VMWare ESXi server and things seem to be back up and running for now.  
> Has anyone ever run into this issue on an intermittent basis before?  If this was a fresh install that would be one thing, but this server has been in place for over a year and this is the first indication of trouble.  Restarting dhcpd nor disabling iptables resolved the problem, nor did a reboot.  What would change for clients to stop responding to offers (or for offers to stop getting to them)?
> Any advice would be appeciated.
> Thanks,
> Scott
> _______________________________________________
> dhcp-users mailing list
> dhcp-users at

More information about the dhcp-users mailing list