static-routes option not working on Android based embedded platform.

Rajeev Bansal rajeev.bansal at
Fri Oct 24 05:57:05 UTC 2014

Dear All,

   My name is Rajeev. I have a use case where I need to push the static
route from a router to a client machine, I am running the Android in my
router. I am using the dhcpd to assign the IP address along with the static
route to the client. I found dhcpd is able to send the static route option
when I run it on my Linux PC and the dhcp client is able to add the static
route in its routing cache. However when I cross compiled the dhcpd for my
target (ARM based android ) it doesn't send the static route options except
that it sends rest all other options. I have tried with the
dhcp-4.1-ESV-R3, dhcp-4.1-ESV-R10, and dhcp-4.2.7 and I found behaviour is
same. Below is my dhcpd.conf

   subnet netmask {
   always-broadcast on;
   default-lease-time 120;
   max-lease-time 120;
   option routers;
   option ip-forwarding off;
   option broadcast-address;
   option subnet-mask;
   option domain-name-servers,;
   option static-routes;

Can someone point me out what is that I am missing on the target. Command
which I uses to launch the dhcps is as follows:

dhcpd -cf /tmp/dhcpd.conf -lf /tmp/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dhcp-users mailing list