Strange behavior No Gateway address after successful IP lease on ISC DHCP Server 4.1

Muhammad Faisal faisalusuf at
Tue Oct 27 18:10:20 UTC 2015

Hello Experts,We have configured the DHCP Server using ISC DHCP server version 4.1 on CentOS. The server deployment remain successful and most of the host are acquiring IP address normally. On of the host is successfully acquiring IP but not the default gateway which is defined in the server as "option routers" parameter under dhcp scope.
I have tried to compare the message of working host with that of problematic one the following differences I have found:
1- Message Size parameter is sent by the problematic client which is a modem Gigaset SX6862- All the messages are same on both problematic client and normal client 3- DHCP is successfully leasing the IP
I have tried hit and trials but no success. The server is operating with default parameters. Can someone please suggest.
#   see 'man 5 dhcpd.conf'#ddns-update-style none;authoritative;one-lease-per-client true;log-facility local0;default-lease-time 600;max-lease-time 600;get-lease-hostnames false;#   parameters for LAN
        subnet netmask {        option routers,;        option subnet-mask;        option broadcast-address;        option domain-name-servers,;        option interface-mtu 1500;        range;
 Regards, Muhammad Faisal.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dhcp-users mailing list