Strange behavior No Gateway address after successful IP lease on ISC DHCP Server 4.1

Muhammad Faisal faisalusuf at
Wed Oct 28 04:50:49 UTC 2015

Hi Judy,Thanks for your response.There is only one dhcp client which has unusual behavior. Rest of the clients are normally working on the same server. Any clue? Regards, Muhammad Faisal.
      From: Judy Hao <Judy.Hao at>
 To: Muhammad Faisal <faisalusuf at>; Users of ISC DHCP <dhcp-users at> 
 Sent: Wednesday, October 28, 2015 3:41 AM
 Subject: RE: Strange behavior No Gateway address after successful IP lease on ISC DHCP Server 4.1
#yiv3598624409 #yiv3598624409 -- _filtered #yiv3598624409 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv3598624409 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv3598624409 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv3598624409 {font-family:Tahoma;panose-1:2 11 6 4 3 5 4 4 2 4;}#yiv3598624409 #yiv3598624409 p.yiv3598624409MsoNormal, #yiv3598624409 li.yiv3598624409MsoNormal, #yiv3598624409 div.yiv3598624409MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:12.0pt;}#yiv3598624409 a:link, #yiv3598624409 span.yiv3598624409MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv3598624409 a:visited, #yiv3598624409 span.yiv3598624409MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv3598624409 span.yiv3598624409EmailStyle17 {color:#44546A;}#yiv3598624409 .yiv3598624409MsoChpDefault {font-size:10.0pt;} _filtered #yiv3598624409 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv3598624409 div.yiv3598624409WordSection1 {}#yiv3598624409 As far as I understand, you can have only one default route and the router must be reachable on your Linux host. Check whether there is already a default route on your DHCP client host. Also check whether you can ping the router (, in your case) on your DHCP client host.    Thanks, Judy    

From: dhcp-users-bounces at [mailto:dhcp-users-bounces at]On Behalf Of Muhammad Faisal
Sent: Tuesday, October 27, 2015 11:10 AM
To: dhcp-users at
Subject: Strange behavior No Gateway address after successful IP lease on ISC DHCP Server 4.1    Hello Experts, We have configured the DHCP Server using ISC DHCP server version 4.1 on CentOS. The server deployment remain successful and most of the host are acquiring IP address normally. On of the host is successfully acquiring IP but not the default gateway which is defined in the server as "option routers" parameter under dhcp scope.    I have tried to compare the message of working host with that of problematic one the following differences I have found:    1- Message Size parameter is sent by the problematic client which is a modem Gigaset SX686 2- All the messages are same on both problematic client and normal client  3- DHCP is successfully leasing the IP    I have tried hit and trials but no success. The server is operating with default parameters. Can someone please suggest.    #   see 'man 5 dhcpd.conf' # ddns-update-style none; authoritative; one-lease-per-client true; log-facility local0; default-lease-time 600; max-lease-time 600; get-lease-hostnames false; #   parameters for LAN         subnet netmask {         option routers,;         option subnet-mask;         option broadcast-address;         option domain-name-servers,;         option interface-mtu 1500;         range; }   Regards, Muhammad Faisal. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the dhcp-users mailing list