VLAN and fixed IPs

Christian Kratzer ck-lists at cksoft.de
Thu Sep 28 10:18:33 UTC 2017


Hi,

On Thu, 28 Sep 2017, Jan Lundmark wrote:
<snipp/>
> Is there a way to assign fixed IP(v4) adresses in dhcpd.conf to clients based on their VLAN membership instead of their subnet?

once you have dhcp snooping setup you can do things like this:

cisco switch:

!
ip dhcp snooping vlan 101
!
interface GigabitEthernet1/0/1
  switchport mode access
  switchport access vlan 101
  ip dhcp snooping vlan 101 information option format-type circuit-id override string foo
!

interface GigabitEthernet1/0/2
  switchport mode access
  switchport access vlan 101
  ip dhcp snooping vlan 101 information option format-type circuit-id override string bar
!

dhcp.conf:

host foo {
     host-identifier option agent.circuit-id "foo";
     fixed-address 192.0.2.1;
}
host bar {
     host-identifier option agent.circuit-id "bar";
     fixed-address 192.0.2.2;
}


>
> Regards
>
> Jan
>
>
>
>
>

-- 
Christian Kratzer                   CK Software GmbH
Email:   ck at cksoft.de               Wildberger Weg 24/2
Phone:   +49 7032 893 997 - 0       D-71126 Gaeufelden
Fax:     +49 7032 893 997 - 9       HRB 245288, Amtsgericht Stuttgart
Mobile:  +49 171 1947 843           Geschaeftsfuehrer: Christian Kratzer
Web:     http://www.cksoft.de/


More information about the dhcp-users mailing list