nnrpd in the latest snapshots segfaults

Kim Alm kea at penti.org
Tue Dec 11 07:53:47 UTC 2001

On Mon, 10 Dec 2001, Jeffrey M. Vinocur wrote:

> On Mon, 10 Dec 2001, Kim Alm wrote:
> > I'm trying to run nnrpd from the latest snapshot with inn 2.3.3 (20011103
> > prerelease), reason for this is that I would like to have two nnrpds on
> > the same server, but different readers.conf files.
> There are other ways to do this.  In the CURRENT tree, nnrpd has a flag
> for specifying an alternative readers.conf file, so you can use the same
> nnrpd repeatedly.  If you want to do this with 2.3 or STABLE, I have a
> patch for it, just ask.

Sorry for being fuzzy, just to clarify things.

- I am running 2.3.3 stable (20011103) on my server.

- I want to be able to have different readers.conf files, and my plan was
to get the source for the 2.4 with the "-c" flag for nnrpd. I downloaded
the inn-CURRENT-20011209. Ran "configure --with-perl ; make", with no
problems at all. Grabbed the binary for nnrpd. But trying to run this
binary, results in a segfault.

> > First question, should this be possible, run the latest nnrpd with an
> > older innd, or is there some library conflict or whatever lurking?
> How much older is your INN installation?  I run 2.4 nnrpd with 2.3.2 INN
> no problems, but it definitely won't work with 2.2.x INN.

Ok, then it should work on my box, but it segfaults when I try to run it.

- Checked the output from the compile, no errors.
- Did a strace, and nothing obvious.

Tried to compile it on my second server runnig inn 2.3.2, the same result.

Any ideas?


More information about the inn-bugs mailing list