nnrpd in the latest snapshots segfaults

Jeffrey M. Vinocur jeff at litech.org
Mon Dec 10 17:22:03 UTC 2001



On Mon, 10 Dec 2001, Kim Alm wrote:

> I'm trying to run nnrpd from the latest snapshot with inn 2.3.3 (20011103
> prerelease), reason for this is that I would like to have two nnrpds on
> the same server, but different readers.conf files.

There are other ways to do this.  In the CURRENT tree, nnrpd has a flag
for specifying an alternative readers.conf file, so you can use the same
nnrpd repeatedly.  If you want to do this with 2.3 or STABLE, I have a
patch for it, just ask.


> I downloaded the latest snapshot inn-CURRENT-20011209,

Ah, CURRENT should be 2.4 prerelease, STABLE is 2.3.3 prerelease.


> First question, should this be possible, run the latest nnrpd with an
> older innd, or is there some library conflict or whatever lurking?

How much older is your INN installation?  I run 2.4 nnrpd with 2.3.2 INN
no problems, but it definitely won't work with 2.2.x INN.

-- 
Jeffrey M. Vinocur
jeff at litech.org



More information about the inn-bugs mailing list