tradspool & inn-2.4

Russ Allbery rra at stanford.edu
Sun Feb 4 17:34:39 UTC 2001



Alexey Luckyanchikov <alexl at alkar.net> writes:

> Today I tried to upgrade to latest inn-2.4. When I ran makehistory I
> received:
> Feb  4 12:29:47 pandora makehistory[64311]: SM storage method 'tradspool' failed initialization
> Feb  4 12:29:47 pandora makehistory[64311]: SM one or more storage methods failed initialization
> Feb  4 12:29:48 pandora makehistory[64312]: tradspool: storeonxref needs to be true
> Why does tradspool require 'storeonxref: true' now?

That's a good question; I'm not entirely sure.  It does have to be true if
you want to duplicate traditional tradspool behavior, though, as older
versions of INN always had storeonxref set to true.

> I set storeonxref to true, but makehistory fail again with message that
> it can't allocate about 600MB of memory. Sorry, now I revert to previous
> version and can't get exactly message :(

Not sure what would cause that; tradspool doesn't allocate large amounts
of memory that I can see and I've not encountered that problem.

-- 
Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>


More information about the inn-bugs mailing list