Patch for compilation errors with INN 2.3.2

Roman Gollent roman at
Wed Jul 25 18:37:11 UTC 2001

I tried STABLE-20010724:

configure:4155: checking for BIO_new in -lcrypto
configure:4174: /tools/ns-arch/soft/sun-workshop-6.0/run/default/sparc_sun_solaris2.6/SUNWspro/bin/cc -o conftest -g   conftest.c -lcrypto  -lelf -lresolv -lnsl  -lsocket -L/usr/local/ssl/lib 1>&5
Undefined                       first referenced
 symbol  /* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char BIO_new();

int main() {
; return 0; }

I am 99% certain that the issue is that -lcrypto comes before
-L/usr/local/ssl/lib in the list of arguments.

FYI, I'm using:
RELEASE VERSION Sun WorkShop 6 update 1 C 5.2 2000/09/11

Also, I will hopefully have some time today to set up a news
server on a test machine in an attempt to produced the
strange history behaviour that we've seen with the cc
compile version of inn.  Sorry about the delay!

Best Regards,

On Wed, Jul 25, 2001 at 07:39:10AM +0900, Katsuhiro Kondou wrote:
>In article <ylelr6m2el.fsf at>,
>	Russ Allbery <rra at> wrote;
>} I tried putting in a different fix for this in STABLE a few days ago too,
>} so you may also want to just try a current STABLE snapshot and see if that
>} works.
>Aha, I've somehow overlooked your commit.  Ok, it works.
>Katsuhiro Kondou

More information about the inn-bugs mailing list