[INN] #78: Add support for Python 3.0

INN rra at stanford.edu
Wed Apr 18 19:46:37 UTC 2018


#78: Add support for Python 3.0
-------------------------+---------------------
 Reporter:  Julien ÉLIE  |       Owner:  eagle
     Type:  defect       |      Status:  closed
 Priority:  medium       |   Milestone:  2.6.3
Component:  build        |     Version:
 Severity:  normal       |  Resolution:  fixed
 Keywords:               |
-------------------------+---------------------
Changes (by Julien ÉLIE):

 * status:  new => closed
 * resolution:   => fixed
 * milestone:  2.6.x => 2.6.3


Old description:

> Python 3.0 was released on December, 3rd.  The syntax currently used in
> Python 2.x scripts shipped with INN is not compatible with the new
> version.  Therefore, innd and nnrpd Python filters should be reviewed and
> made compatible with both Python 2.x and 3.0.
>
> Compilation with Python 3.0 API should also be checked (new functions to
> use? no issue when building INN with Python support?)
>
> Also be sure that INN compiles fine with Python 2.5.x and 2.6.x.

New description:

 Python 3.0 was released on December, 3rd 2008.  The syntax currently used
 in Python 2.x scripts shipped with INN is not compatible with the new
 version.  Therefore, innd and nnrpd Python filters should be reviewed and
 made compatible with both Python 2.x and 3.0.

 Compilation with Python 3.0 API should also be checked (new functions to
 use? no issue when building INN with Python support?)

 Also be sure that INN compiles fine with Python 2.5.x and 2.6.x.

--

Comment:

 Fixed in commit [10276].  Tested with Python 2.7, 3.3 and 3.6.

--
Ticket URL: <http://inn.eyrie.org/trac/ticket/78#comment:9>
INN <https://www.eyrie.org/~eagle/software/inn/>
InterNetNews


More information about the inn-bugs mailing list