Perl filtering

Dickon Hood dickon.hood at
Mon Jul 3 15:45:47 UTC 2000

On Fri, Jun 30, 2000 at 15:50:57 -0700, Russ Allbery wrote:
: Dickon Hood <dickon.hood at> writes:
: > I'm having some *real* problems with Perl filtering on innd 2.2.2.
: > Basically, any filter which 'use'es something non-trivial (eg, 'use lib'
: > and 'use strict' work, but 'use IO::Socket' doesn't) kills the daemon,
: > whether invoked from startup or ctlinnd reload.

: > trussing the process suggests that Perl is dying after writing 'panic:
: > top_env' to stderr.  Looking through the Perl source has left me
: > somewhat unenlightened, and I'm now getting rather stuck.  Perl
: > 5.004_04, inn 2.2.2, Solaris 7 on 64-bit Ultras.  Freshly compiled from
: > source about a fortnight ago.

: > Anyone seen this before, or have any idea what the problem is?

: I've not seen this before, I'm afraid.  :/  I've not tested Perl filtering
: with Perl 5.004_04 in quite a while, though.  Is it an option to try
: upgrading to 5.005_03 or 5.6.0?

OK, I've tried that with the same result.  I've tried 5.004_0[45],
5.005_03, and failed to get 5.6.0 to work with 2.2.2.  The three versions
of Perl I have got working do the same thing: print 'panic: top_env' and
quit.  According to perldiag, it's a fatal error do with the interpreter
going a goto 'or something weird like that'.

I've now decided I might as well try to upgrade to a later inn, the
problem being that I can't actually find one :-)  People here talk about
2.3.0beta etc., but I can't find it.  Anyone care to tell me where it
would be?


Dickon Hood

BBC Internet Services,
Kingswood Warren.
+44 1737 839754.

More information about the inn-workers mailing list