Possible Solaris 8/INN-2.3.2 Problem

Timothy Demarest demarest at arraycomm.com
Sat May 19 05:12:35 UTC 2001


I've got a strange problem that I've reached my wits end with.
I was happily running inn-2.3.0 on a Solaris 8 box with no
problems. I had noting better to do, so i thought that I'd
upgrade to inn-2.3.2. Since it was a "minor" update, I thought
that it would be easy.

I compiled 2.3.2 with the same options as 2.3.0. We are currently
using Berkeley DB 3.1.la, so after doing a 'make update', I ran
the ovdb_upgrade. No problems. Thinking I was done, I started news
in our normal fashion. Everything appeared to start just fine.
However, telnetting to port 119 or trying to run any newsreaders
does not produce any results. The newsreaders timeout, the telnet
attempt doesn't return the INN banner. Also, 'ctlinnd mode' hangs
indefinitely, and the shuitdown process doesn't work. The innd
process is running. There are no errors in the logs.

I tried back revving to a newly compiled 2.3.0 (to match the
Berk DB version), but it doesn't like Berk DB 3.x. So, I tried
2.3.1 with the same results as 2.3.2.

Has anyone seen this behavior, or have any helpful advice?

Thanks.

--
Timothy Demarest                      ArrayComm, Inc.
demarest at arraycomm.com                2480 N. 1st Street, Suite 200
http://www.arraycomm.com              San Jose, CA 95131


More information about the inn-workers mailing list