forwarding email to inn

Bill Tangren bjt at aa.usno.navy.mil
Wed Sep 12 19:02:45 UTC 2001


I did this, and I still get the same error:

inews failed: sh: /usr/local/news/bin/inews: Permission denied

I am running inn 2.3.2. Could it be that the symbolic link for mailpost in 
/etc/smrsh needs to be owned by news?

Bill Tangren

> 
> I had this problem with INN 2.2.3 (on Solaris 7).  The problem was that
> inews writes to pathtmp (/usr/local/news/tmp, in my case), so it wouldn't
> work unless inews was run by user news, not the case for
> sendmail->mailpost.  I was under the impression this would be fixed in
> 2.3.  Then again, you don't say (or I missed it) which version of INN you
> have.
> 
> Anyway, the solution for me was to make inews setgid news and make pathtmp
> group-writable by group news.  I expect you can do this (as root) with
> 
>   chmod g+xs /usr/local/news/bin/inews
>   chmod g+rwx /usr/local/news/tmp
> 
> so inews should be -r-xr-s---   news:news
> and pathtmp should be drwxrwx---   news:news
> 
> Michael
> 
> On Wed, 12 Sep 2001, Bill Tangren wrote:
> 
> > 
> > I did this, and I now get the error:
> > 
> > inews failed: sh: /usr/local/news/bin/inews: Permission denied
> > 
> > After looking at some archived posts to this list serv, I think this is caused by 
> > not having a flag "--enable-setgid-inews" set on ./configure of inn. Is this true? Will 
> > this fix the problem?
> > 
> > Bill Tangren
> > 



More information about the inn-workers mailing list