cnfs buffer won't initialize.

jarrell at jarrell at
Sat Sep 29 03:59:59 UTC 2001

Ok, I have a block of identical 36.4G 10K rpm drives on my machine.
I just added 2 new ones, and was trying to add them into the cycbuff
config.  Now, one's being used to expand the partition the overview
data is in, because space there was getting tight.  The other is joining
its fellow drives in the cycbuff pool.  Each of these drives has an
identical partition table, and is set up identically.  The new drive,
c5t1d0 works fine (after I started having problems, I created a
filesystem in the suspect partition, and it mounted and filled with
data just fine.)

The partition table I use is:

Current partition table (original):
Total disk cylinders available: 24620 + 2 (reserved cylinders)

Part      Tag    Flag     Cylinders         Size            Blocks
  0       root    wm       0 -     0        1.41MB    (1/0/0)         2889
  1 unassigned    wm       0                0         (0/0/0)            0
  2     backup    wu       0 - 24619       33.92GB    (24620/0/0) 71127180
  3 unassigned    wm       0                0         (0/0/0)            0
  4 unassigned    wm       0                0         (0/0/0)            0
  5 unassigned    wm       0                0         (0/0/0)            0
  6        usr    wm       1 - 24619       33.91GB    (24619/0/0) 71124291
  7 unassigned    wm       0                0         (0/0/0)            0

0 has 1 cylinder so cnfs won't step on the partition table, I left
2 alone, and am using 6.

I create fake device entries in /cycbuff and make them owned by news so
it's easier to let news dink with the devices.  I've verified that I'm
using the right device numbers, and this has worked for years with the other

Every one of them has a line like:


(this is, in fact, the line that's not working.  It's identical to,
say, the previous one, except that says 5-0-6 everywhere this one says

It's not in any metacycbuffs yet.  

Every time INN tries to initialize the storage manager though,
it fails on this cycbuff.  I get:

Sep 28 23:45:34 solaris sm[1506]: [ID 471003 news.warning] CNFS-sm: No magic cookie found for cycbuff d5-1-6, initializing
Sep 28 23:45:34 solaris sm[1506]: [ID 954692 news.error] CNFS-sm: CNFSflushhead: write failed (-1 bytes): Bad file number
Sep 28 23:45:34 solaris sm[1506]: [ID 371779 news.error] SM storage method 'cnfs' failed initialization
Sep 28 23:45:34 solaris sm[1506]: [ID 292155 news.error] SM one or more storage methods failed initialization

And no cookie gets written to the device.  If I comment out 5-1-6 life is
fine.  I've got 8 cycbuffs defined.  Another has been defined for about
a month, but not actually used, so I tried commenting it out, incase
for some reason 8 was too many, but no, that doesn't help.  I even created
a fake configuration with *just* the d5-1-6 configured as a cycbuff, in
a metabuff called TEST, and set up storage.conf to write everything to 
TEST, and just tried to do an "sm" of a token in my history file,
and got the same error.

What in hell is going on?  This has got me *really* annoyed, because I
can't find a thing wrong with the system, yet it doesn't work.

More information about the inn-workers mailing list