Fwd: mailpost failure

Steven L. Sesar ssesar at mitre.org
Thu Jan 24 13:52:14 UTC 2002

This was touched upon in a previous post, but I'm still having problems.
error I get is:

inews failed: sh: /news/bin/inews: cannot execute

I have the following entry in my /etc/mail/aliases file:

netnews-test-list: "| /news/bin/mailpost local.news.test"

The following in ~news/etc/news2mail.cf:

netnews.test.list at newssrv.myco.org netnews-test-list at lists.myco.org

The following in ~news/etc/newsfeeds:

netnews.test.list at newssrv.myco.org/mailpost:local.news.test:Tm,Ac:n2m!

- yes, I ran "newaliases"
- yes, I made the proper configuration on the listserv machine.

-r-xr-s---   1 news     news      190723 Dec 13 16:21 inews
drwxrwxrwx   2 news     news         512 Jan 24 03:38 tmp

When I "tail -f /var/adm/maillog", while sending both a message to the
mailing list and an article to the newsgroup, sendmail behaves the way I
expect and the message is queued, then sent.

However, the gateway still doesn't work in either direction. All I get
is the
error above. I did see a mention in  a previous post regarding a link to
/usr/adm/sm.bin, but I can't see that in any documentation.


More information about the inn-workers mailing list