"access: A" in STABLE (was: Patches from CVS)

Bettina Fink laura at hydrophil.de
Thu Jan 31 00:24:33 UTC 2002

Jeffrey M. Vinocur <jeff at litech.org> wrote:

>> I ran into that "access: A" thing today
>> with both inn-STABLE-20020124 and -20020130 (posting with "Approved"
>> header to moderated newgroup rejected "post failed You are not allowed
>> to approve postings" despite "access: RPA").
> Hrm.  I haven't actually tried to use that code to restrict access; I
> don't know if it works or not.  I believe I correctly ported it from
> CURRENT, and the code in CURRENT does work.

AFAICS, it doesn't work. I've tried with different snapshot versions
and servers and double-checked my readers.conf:

access "local users" {
        users: "<inx>, <home>, <localhost>"
        newsgroups: "*"
        access: RPA
        localtime: true

Jan 30 16:43:25 wuff nnrpd[744]: absinth.snafu.net res <inx>
Jan 30 16:43:25 wuff nnrpd[744]: absinth.snafu.net match_user <inx> <inx>,<home>,<localhost>

So it's the correct access group with "RPA", but:

Jan 30 16:44:13 wuff nnrpd[744]: absinth.snafu.net post failed You are not allowed to approve postings

This was with STABLE-20020128 and STABLE-20020130.

>> I switched back to STABLE-20011201, were it worked (tested a few moments
>> ago).
> Are you sure?  I believe that release will allow everyone to post Approved
> regardless of the presence or absence of "access: A".

mmmh, I only checked if posting with Approved headers works, not if
the absence of "A" prevents postings with Approved. Maybe the old
code is broken the other way round, but I have several users that
post FAQs or are moderators, so for me "all" is a better choice than
"none" ...


More information about the inn-workers mailing list