nnrpd_auth.pl loading issues

Mike Mondragon mike at mondragon.cc
Tue Mar 26 17:56:58 UTC 2002


Sundaram, inn-workers,

Yes, I did the basic debugging by appending lines to a log file to see
which nnrpd_auth.pl methods (if any) are being called by nnrpd.  None.

Yes, my nnrpd_auth.pl is syntactically proper as I wrote a main script to
test the authenticate subroutine stand-alone from the nnrpd on the command
line and was able to run authenticate stand-alone.

I might not have been clear about this, but the perl script that I wrote
to run from readers.conf for auth: purposes against MySQL worked just
fine.  So perl is working.

I would be most appreciative if someone with core knowledge could give me
some debugging tips for nnrpd_auth.pl ... I can't even find anywhere in
the documentation to turn on verbose debugging logging for nnrpd ... at
this point I can't even verify that that nnrpd opens nnrpd_auth.pl.

Thanks
Mike

On Mon, 25 Mar 2002, Sundaram Divya-QDIVYA1 wrote:

> Yes,
>
> I am working on something similar for LDAP and use the following
> debugging technique.
>
> In my PERL routine, I have a DEBUG level that, if set, prints
> out messages to a LOG file. The routine opnes the Log File,
> writes a message and then closes the LogFile. While this is rather
> inefficient, it is a good way to test over short periods of time.
>
> With appropriate print statements, what this will show is what
> parts of the script are being run and, if you keep tabs also on
> the variables, what variables are bing returned.
>
> I would try something like that to see if the perl script is being
> correctly called ... also, please ensure that your Perl Modules
> are available (I built and used my own Perl even though RH 7.2
> have Perl 5.6.0. to ensure that I had FULL control over my perl
> installation.
>
> I hope that this helps. Good luck.
>
> Regards
>
> Divya Sundaram ----------------------------- CONDITUR IN PETRA
> We don't need more strength, or greater opportunity. What we
> need is to use what we have.                  - BASIL S. WALSH
> --------- Motorola OneIT -- Enabling the Enterprise ----------
>
>
> -----Original Message-----
> From: Mike Mondragon [mailto:mike at mondragon.cc]
> Sent: Monday, March 25, 2002 9:08 PM
> To: inn-workers at isc.org
> Subject: nnrpd_auth.pl loading issues
>
>
>
> inn-workers:
>
> I am having problems getting nnrpd_auth.pl to load correctly.
> I have tried this on two separate systems, one with INN-2.3.2 built from
> tar (with all options, including perl) and the other INN-2.3.2 from the
> RedHat 7.2 distro.
>
> I have double checked my inn.conf and
> "nnrpperlauth: true"
> is set and
> "pathfilter:  /usr/local/news/bin/filter"
> is also set and is an existing directory on the systems.
>
> I had written a perl script that mimics the functionality of ckpasswd but
> does the authentication from data stored on a MySQL DB.  I correctly used
> this custom authenticator in readers.conf by testing good and bad user
> names and passwords.  At that time I set the inn.conf to do authentication
> via the nnrpd_auth.pl noted in my inn.conf settings above, rewrote the
> "authenticate" perl subroutine in nnrpd_auth.pl, and restarted the server.
> I tailed /var/log/messages and /usr/local/news/log/news.notice (mored err
> and crit) to watch that everything started back up OK.  Now when I tested
> my user name and passwords the server would give me 502's from my testing
> remote host, and when testing from localhost would 381/281 for any
> username password combination whether they were valid or not.
>
> I could not find anything in the log files to indicate that nnrpd_auth.pl
> had loaded correctly or if it loaded had perl or MySQL errors.
>
> Any ideas?
> Thanks
> Mike
>
>



More information about the inn-workers mailing list