can't post article .

kajan kajan at singnet.com.sg
Thu May 16 18:29:01 UTC 2002


Hi all,

First of all sorry for posting question again. I have tried to give more
details about my problem.

" I have one server (server1) for receiving & sending articles to upstream
news provider & to store all the articles.

I have two reader servers & I have configured them to mount the
/usr/local/news & var/spool/news volumes from the server1.
(All running redhat 7.2 with INN 2.3.3).

I have copied the nnrpd file from /usr/local/news/bin to /usr/local/etc."

The entries in exports file in reader server as follows:
/usr/local/news xxx.xxx.xxx.xxx(rw,no_root_squash)
/var/spool/news xxx.xxx.xxx.xxx(rw,no_root_squash)

The entries in fstab file in reader server as follows:

xxx.xxx.xxx.xxx:/usr/local/news    /usr/local/news nfs      exec,dev,suid,rw
0 0
xxx.xxx.xxx.xxx:/var/spool/news    /var/spool/news nfs      exec,dev,suid,rw
0 0

contents of /etc/xinetd.d/nntp is as follows:

service nntp
{
        socket_type     = stream
        protocol         = tcp
        wait               = no
        user              = news
        server           = /usr/local/etc/nnrpd

Now if I post article staight to server1, I can past article.

But for reader server I can subcribe to the news groups & view the articles
in outlook express.

But If I post new article, it just dissapears. /var/log/messages file says
posted ok. But news.notice in the mounted partition is not updated.

I am using timehash storage method. Will using tradspool storage method
help?

My present setup is one innd server & 4 reader server are mounting common
partion from netapp filer.
But I run 1.7.2. I have to update because of old hardware.

I also found out from the archive that It is difficult to run nfs with new
version of INN.
Can it be done with some chnge in settings?. Or some coding has to be done.
Pl.let me know. I have to meet some deadline in this upgrading project.

Thanks for the earlier helps.

Regards

Kajan







More information about the inn-workers mailing list