[ssundell at pp.htv.fi: Bug#179898: inn2: Problems with history and overview creation]

Russ Allbery rra at stanford.edu
Mon Feb 10 03:04:46 UTC 2003


> I tried checking what might be wrong, and finally tried to recreate the
> history. Result?

> makehistory: no Message-ID header in @030042554646310000000000013000000001@

What are the results of:

    sm @030042554646310000000000013000000001@ | grep -i message-id

?  If the storage manager is returning some sort of nonsense, that could
explain this.  Otherwise, it sounds like there's some problem with
makehistory parsing the message headers.

> I tried to check any configuration errors, but so far I haven't found
> anything that could have caused this. I have changed nothing for a
> while, except the hismethod and all that needed by the upgrade.

I've not seen this before.  Something sounds really severely broken about
your INN installation.

Is there any chance that you have something weird like shared libraries
from the previous version of INN in combination with binaries from a later
version of INN?  This sounds like the sort of thing that would result if
the program and the shared libraries didn't agree on APIs.  (Right now,
INN's shared libraries aren't properly versioned.)

-- 
Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>

    Please send questions to the list rather than mailing me directly.
     <http://www.eyrie.org/~eagle/faqs/questions.html> explains why.


More information about the inn-workers mailing list