Problem with history - cant fgets after article

Steve Youngs sryoungs at
Sun Jan 4 00:37:17 UTC 2004

|--==> "RA" == Russ Allbery <rra at> writes:

  RA> Steve Youngs <sryoungs at> writes:
  >>I just re-configured with `--disable-keywords', re-built, and
  >>re-installed... Turned off keywords in inn.conf...  It didn't make
  >>any difference.  I still get the `can't fgets after article'. :-(

  RA> That makes me worried that there's some sort of malloc heap
  RA> corruption, since that's where innd died (in a malloc called by
  RA> regexec).  innd dies right after you get that message, right?


  RA> Is there any way that you could run innd under valgrind or
  RA> purify or something along those lines and see if it turns up
  RA> where the memory corruption may be happening?

Well I tried.  Downloaded valgrind, but I couldn't figure out how to
make it play nice. :-(

  `valgrind --trace-children=yes --logfile=/tmp/inn-grind'

...produced lots of log files in /tmp, but none of them seemed to
pertain to innd.  No doubt I'm doing something stupid.  What do I need
to do to collect the information you're looking for?

|---<Steve Youngs>---------------<GnuPG KeyID: A94B3003>---|
|              Ashes to ashes, dust to dust.               |
|      The proof of the pudding, is under the crust.       |
|------------------------------<sryoungs at>---|

More information about the inn-workers mailing list