Undefined reference to txn_abort/txn_begin/txn_commit

Toon van der Pas toon at hout.vanvergehaald.nl
Wed Jan 28 18:14:52 UTC 2004


On Mon, Jan 26, 2004 at 03:12:09PM -0800, Russ Allbery wrote:
> Toon van der Pas <toon at hout.vanvergehaald.nl> writes:
> > On Sun, Jan 25, 2004 at 02:03:30PM -0800, Russ Allbery wrote:
> 
> >> Could you try the following patch and see if it fixes your problem?
> >> Please let me know if it does, and I'll add it to STABLE and the next
> >> patch release.  Although it really *shouldn't* based on the output that
> >> you showed, unless you somehow have 4.2 headers with your 4.0 library.
> 
> > Well, it didn't make any difference.
> 
> Yeah, you really do have 4.0, and that patch only triggered on 4.1
> or later.  If you feel like giving it one more try, I think the
> patch I posted in response to Marco a little bit ago will actually
> work for you. I think I have a fuller understanding of the issue
> now.

It sure looks like you have a fuller understanding of the issue now.
I recreated the history and overview databases overnight.
The makehistory command completed without any sign of trouble.
I started INN just a moment ago (I manage this server in my spare time).
It works. I can read news. You are fantastic!

Now I will test it some more, like posting etc.
But my trust in a good ending has increased enormously.

Regards,
Toon.

BTW: I don't know wether you want to apply the patch to STABLE yet.
It's up to you. I'll keep you informed of the status over here.
-- 
"The more difficult a decision is to make,
 the less it matters what you decide."
                    -- Eugene Kleiner


More information about the inn-workers mailing list