innd dies after first post

Dominik Klein Dominik.Klein at
Fri Oct 8 11:59:14 UTC 2004

> Check with strace what is happening, 

This is all I can see what went wrong:

setgroups32(1, [1007])                  = -1 EPERM (Operation not permitted)
setresuid32(-1, 0, -1)                  = -1 EPERM (Operation not permitted)

I am not too familiar with strace but I think this is about it.

What came to my mind then is that I did not "make install" as root but 
as news (directories were prepared).
So I deleted /news and /usr/local/news and reinstalled the whole thing 
as root. I need to use separate directories because we're going to 
install INN with on discspace shared between two cluster machines.

Unfortunately it does exactly the same things now after "make install" 
as root. Well, it does not give those "Operation not permitted" errors 
any more...

> it may be a perl problem.

Can't see anything concerning perl in the logs and strace.

Tried to install 2.4.1 on a solaris and on a linux machine,

news at wooza:$ uname -a
Linux wooza 2.4.27-1-k6 #1 Fri Sep 3 06:18:16 UTC 2004 i586 GNU/Linux
news at wooza:$ perl --version
This is perl, v5.8.4 built for i386-linux-thread-multi

bash-2.05$ uname -a
SunOS clustera 5.9 Generic_117171-02 sun4u sparc SUNW,Sun-Fire-280R
bash-2.05$ perl --version
This is perl, v5.6.1 built for sun4-solaris-64int

So perl even is a different version and INN does the same error, so I 
don't think it's a perl error? Hm, don't know actually.

More information about the inn-workers mailing list