expire doesn't expire, what have I done wrong - any ideas?

zakina at nz.bluescopesteel.com zakina at nz.bluescopesteel.com
Wed Feb 8 00:49:43 UTC 2006


hi,
back in November I installed INN 2.4.2 on RH3.0 ES and started a new 
spool with a subset of groups using newsx to get articles.

I set up expire.ctl as :-
---
/remember/:40

##  Keep for 1-10 days, allow Expires headers to work.  This entry 
uses
##  the syntax appropriate when groupbaseexpiry is true in inn.conf.
*:A:1:30:40

##  Keep for 1-10 days, allow Expires headers to work.  This is an 
entry
##  based on storage class, used when groupbaseexpiry is false.
#0:1:10:never
# get rid of alt.* as it is not imported at all
alt.*:A:1:2:2

microsoft.*:A:1:30:40
comp.*:A:1:30:40
quics.*:A:1:21:21


# These groups have 5 times as much traffic as anything else
biz.jobs.offered:A:1:2:2
control.cancel:A:0:0:0
junk:A:0:0:0
---
I set Article storage in inn.conf to 
---
# Article Storage

cnfscheckfudgesize:     0
enableoverview:         true
groupbaseexpiry:        true
mergetogroups:          false
overcachesize:          15
#ovgrouppat:
storeonxref:            true
useoverchan:            false
wireformat:             false
xrefslave:              false
nfswriter:              false
---
and used the tradspool method of storage.

The expire process has never really expired any articles in the 
numbers I would expect, ocaasionally 1or 2 articles but not the 
hundreds or thousands I would expect on a daily basis. A check of 
history shows articles still being retained from back in Nov 2005 
when the spool started.
eg 
[news:netman:db]$head -1 history
[37EBC6568827468F367D9DDD0E65E1BC]      1131556462~-~1131527412 
@05000000002700003EBC0000000000000000@
[news:netman:db]$sm @05000000002700003EBC0000000000000000@ |grep Date
Date: Wed, 09 Nov 2005 09:10:12 GMT
NNTP-Posting-Date: Wed, 09 Nov 2005 02:10:12 MST

I run news.daily every day from cron
---
0 1 * * * /usr/local/news/bin/news.daily delayrm expireover
---
A sample of the output from this is
-----
expireover start Wed Feb  8 13:04:21 NZDT 2006: ( -z 
/usr/local/news/log/expire
.rm)
    Article lines processed     6976
    Articles dropped               0
    Overview index dropped         0
expireover end Wed Feb  8 13:04:23 NZDT 2006
expire begin Wed Feb  8 13:04:53 NZDT 2006: (-v 5 
/usr/local/news/etc/expire.ctl
)
    Article lines processed   187400
    Articles retained         187400
    Entries expired                0
expire end Wed Feb  8 13:04:58 NZDT 2006
        all done Wed Feb  8 13:04:58 NZDT 2006
----

Can anyone suggest what I might have missed or misconfigured that is 
preventing expire from getting rid of these old articles.

I previously had been running an older version of INN  on older 
hardware and RH 6.0 and it worked great. 
The INN software upgrade coincided with hardware and OS upgrade.

TIA
Andrew.


More information about the inn-workers mailing list