No articles are seen through the news clients

Hirantha Wijayawardena hirantha at vcs.informatics.lk
Wed Feb 28 08:36:17 UTC 2007


Hi,
I'm trying to setup INN for last couple of days, still not seeing a posted
article on Thunderbird/Outlook Express. I'm on Redhat ES 4 with inn-2.3.5
rpm installations. I am newbie to the news and INN.
What I wanted is - simple internal news server which all users could
post/read using thunderbird/outlook express.

Here are my config files;
inn.conf:

mta:                    /usr/sbin/sendmail -oi -oem %s
ovmethod:               tradindexed
pathhost:               informatics.lk
pathnews:               /usr/lib/news
..
spoolfirst: false
mailcmd:                /usr/lib/news/bin/innmail
server:			localhost
..
patharchive:            /var/spool/news/archive
patharticles:           /var/spool/news/articles
pathbin:                /usr/lib/news/bin
pathcontrol:            /usr/lib/news/bin/control
pathdb:                 /var/lib/news
pathetc:                /etc/news
pathfilter:             /usr/lib/news/bin/filter
pathhttp:               /var/log/news
pathincoming:           /var/spool/news/incoming
pathlog:                /var/log/news
pathoutgoing:           /var/spool/news/outgoing
pathoverview:           /var/spool/news/overview
pathrun:                /var/run/news
pathspool:              /var/spool/news
pathtmp:                /var/lib/news/tmp

newsfeeds:
#ME:!*/!control,!junk,!local,!lists::

# innfeed funnel master.
innfeed!\
        :!*\
        :Tc,Wnm*:/usr/lib/news/bin/startinnfeed

controlchan!\
        :!*,control,control.*,!control.cancel\
        :Tc,Wnsm:/usr/lib/news/bin/controlchan

readers.conf:
auth "local_ips" {
    hosts: "*"
    default: "<user>"
    default-domain: "informatics.lk"
}
access "local_ips" {
    users: "*@informatics.lk"
    newsgroups: "*,!control*,!junk"
    access: "Read Post"
}

incoming.conf:
streaming:              true   # streaming allowed by default
max-connections:        8      # per feed

peer ME {
  hostname:         "localhost, 127.0.0.1, rhel4.informatics.lk"
}

ls -al /var/spool/news/

drwxr-xr-x  2 news news 4096 Dec  7  2004 archive
drwxr-xr-x  2 news news 4096 Dec  7  2004 articles
drwxrwxr-x  3 news news 4096 Feb 27 16:05 incoming
drwxr-xr-x  2 news news 4096 Feb 27 21:04 innfeed
drwxr-xr-x  2 news news 4096 Dec  7  2004 outgoing
drwxr-xr-x  3 news news 4096 Feb 27 12:32 overview
-rw-rw-r--  1 news news  106 Feb 23 16:41 tradspool.map

storage.conf:

method tradspool {
        newsgroups: *
        class: 0
}


I checked with inncheck and there are no errors on the config files. While
I'm posting article from the news client, I can see the post has received by
the server.

news.notice:
Feb 27 16:05:44 rhel4 nnrpd[31926]: 192.168.128.230 connect
Feb 27 16:05:44 rhel4 nnrpd[31926]: 192.168.128.230 post ok
<es11i0$v5m$1 at rhel4.informatics.lk>
Feb 27 16:05:44 rhel4 nnrpd[31926]: 192.168.128.230 posts received 1
rejected 0
Feb 27 16:05:44 rhel4 nnrpd[31926]: 192.168.128.230 times user 0.019 system
0.026 elapsed 0.285


And I can see mail is getting loop on the sendmail after I setup
/etc/aliases:
news:          "|/usr/lib/news/bin/mailpost -d localhost local.test"


/var/log/mailllog:

Feb 27 21:02:53 rhel4 sendmail[8922]: l1RFWrqs008922:
from=<mail at rhel4.informatics.lk>, size=13882, class=0, nrcpts=1,
msgid=<200702271532.l1RFWqhe008921 at rhel4.informatics.lk>, proto=ESMTP,
daemon=MTA, relay=rhel4.informatics.lk [127.0.0.1]
Feb 27 21:02:53 rhel4 sendmail[8921]: l1RFWqhe008921: to=news, ctladdr=mail
(8/12), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=43579,
relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l1RFWrqs008922 Message
accepted for delivery)
Feb 27 21:02:53 rhel4 sendmail[8917]: l1RFWpnG008916:
to="|/usr/lib/news/bin/mailpost -d localhost local.test",
ctladdr=<news at rhel4.informatics.lk> (8/0), delay=00:00:02, xdelay=00:00:02,
mailer=prog, pri=43309, dsn=2.0.0, stat=Sent

Feb 27 21:02:53 rhel4 sendmail[8922]: l1RFWrqs008922:
from=<mail at rhel4.informatics.lk>, size=13882, class=0, nrcpts=1,
msgid=<200702271532.l1RFWqhe008921 at rhel4.informatics.lk>, proto=ESMTP,
daemon=MTA, relay=rhel4.informatics.lk [127.0.0.1]
Feb 27 21:02:53 rhel4 sendmail[8921]: l1RFWqhe008921: to=news, ctladdr=mail
(8/12), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=43579,
relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (l1RFWrqs008922 Message
accepted for delivery)
Feb 27 21:02:53 rhel4 sendmail[8917]: l1RFWpnG008916:
to="|/usr/lib/news/bin/mailpost -d localhost local.test",
ctladdr=<news at rhel4.informatics.lk> (8/0), delay=00:00:02, xdelay=00:00:02,
mailer=prog, pri=43309, dsn=2.0.0, stat=Sent

I tried rnews -v -U then 
news.notice:
Feb 27 21:07:01 rhel4 rnews: cant open_remote Success

There are messages are sitting in the /var/spool/news/incoming directory

ls -al /var/spool/news/incoming/

-rw-rw-r--  1 news news  638 Feb 27 15:07 45e3fbf1PwCa7F
-rw-rw-r--  1 news news  646 Feb 27 16:05 45e40980G8NaYG
drwxrwxr-x  2 news news 4096 Feb 27 12:32 bad

Here are my telnet sessions:

Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
200 .. InterNetNews server INN 2.3.5 ready
mode reader
200 InterNetNews NNRP server INN 2.3.5 ready (posting ok).
list
215 Newsgroups in form "group high low flags".
local.test 0000000000 0000000001 y
.
group local.test
211 0 0 0 local.test
xover
224 0 fields follow
.

I don't see any errors on the log except:

/var/log/news/news.err:
Feb 27 12:34:17 rhel4 innd: SERVER perl filter not defined
Feb 27 15:05:22 rhel4 innd: SERVER perl filter not defined
Feb 27 15:07:43 rhel4 innd: SERVER perl filter not defined

And mail loop.

I don't see any messages through the client. Am I missing something.. Can
some one point me in the right direction?

Thanks in advance

- Hirantha




_________________________________________________________________ 
e'switch 3.2.5 w/ MySQL on RedHat Enterprise 4 in production
RedHat Cluster Suite v4 on RedHat Enterprise 4 in production
Oracle 10g R2 on RedHat Enterprise 4 in production
 
_________________________________________________________________ 
Disclaimer and Confidentiality
 

This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the system manager. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited.




More information about the inn-workers mailing list