Something not correct in the CURRENT branch

The Doctor doctor at doctor.nl2k.ab.ca
Thu Aug 21 14:23:07 UTC 2008


Right

I use

CC=/usr/bin/gcc  SENDMAIL=/usr/sbin/sendmail  PERL=/usr/bin/perl  PYTHON=/usr/contrib/bin/python  YACC=/usr/bin/yacc  AWK=/usr/bin/awk  EGREP=/bin/egrep  SED=/usr/bin/sed  SORT=/bin/sort  SSLBIN=/usr/contrib/bin UUX=/usr/bin/uux BZIP2=/usr/contrib/bin/bzip2 COMPRESS=/usr/bin/compress GZIP=/usr/contrib/bin/gzip ./configure --build=i386-pc-bsdi --host=i386-pc-bsdi --target=i386-pc-bsdi --prefix=/var/news --bindir=/var/news/bin --sbindir=/var/news/bin --libexecdir=/var/news/libexec --sysconfdir=/var/news/etc --sharedstatedir=/var/news/com --localstatedir=/var --libdir=/var/news/lib --includedir=/var/news/include --oldincludedir=/usr/include --datarootdir=/usr/share --htmldir=/var/www/docs/news --enable-shared --enable-static --enable-fast-install --enable-setgid-inews --enable-uucp-rnews --enable-ipv6 --enable-tagged-hash --enable-keywords --with-db-dir=/var/news/etc  --with-log-dir=/var/log/news --with-syslog-facility=LOG_NEWS --with-news-user=bin
--with-news-group=uucp --with-news-master=usenet --with-log-compress=gzip --with-sendmail=/usr/sbin/sendmail --with-innd-port=119 --with-perl --with-python --with-berkeleydb=/usr --with-zlib=/usr --with-openssl=/usr/contrib --with-sasl=/usr/contrib 

for configuration.

I use perl 5.8.8 and the -n flag does not work.

I run the tests:

./runtests TESTS

Running all tests listed in TESTS.  If any tests fail, run the failing
test program by hand to see more details.  The test program will have the
same name as the test set but with ".t" appended.

authprogs/ckpasswd......ok
authprogs/domain........ok
authprogs/ident.........MISSED 1-4 (exit status 1)
clients/getlist.........ok
innd/artparse...........ok
innd/chan...............ok
lib/asprintf............ok
lib/buffer..............ok
lib/concat..............ok
lib/conffile............ok
lib/confparse...........ok
lib/date................ok
lib/dispatch............ok
lib/getaddrinfo.........FAILED 72
lib/getnameinfo.........ok
lib/hash................ok
lib/hashtab.............ok
lib/hex.................ok
lib/hstrerror...........ok
lib/inet_aton...........ok
lib/inet_ntoa...........ok
lib/inet_ntop...........ok
lib/innconf.............ok
lib/list................ok
lib/md5.................ok
lib/memcmp..............ok
lib/messages............ok
lib/mkstemp.............ok
lib/network.............MISSED 1-117 (exit status 1)
lib/pread...............ok
lib/pwrite..............ok
lib/qio.................ok
lib/setenv..............ok
lib/snprintf............ok
lib/strerror............ok
lib/strlcat.............ok
lib/strlcpy.............ok
lib/tst.................ok
lib/uwildmat............ok
lib/vector..............ok
lib/wire................ok
lib/xmalloc.............ok
lib/xwrite..............ok
nnrpd/auth-ext..........ok
overview/api............ok (skipped 6 tests)
overview/buffindexed....ok
overview/overchan.......ok
overview/tradindexed....ok
overview/xref...........ok
storage/archive.........ok
storage/makehistory.....ok
storage/sm..............ok
util/convdate...........ok
util/innbind............ok (skipped 5 tests)
util/inndf..............ok
util/innupgrade.........ok

Failed Set                 Fail/Total (%) Skip Stat  Failing Tests
-------------------------- -------------- ---- ----  ------------------------
authprogs/ident               4/4    100%    0    1  1-4
lib/getaddrinfo               1/75     1%    0    0  72
lib/network                 117/117  100%    0    1  1-117

Failed 122/2884 tests, 95.77% okay, 11 tests skipped.
Files=56,  Tests=2884,  35.63 seconds (0.82 usr + 2.61 sys = 3.43 CPU)
gmake[1]: *** [test] Error 1
gmake[1]: Leaving directory `/usr/source/inn-CURRENT-20080816/tests'
gmake: *** [test] Error 2                 

Examining the authprogs/ident test

./ident.t
4
cannot bind socket for 127.0.0.1,11119: Can't assign requested address
cannot bind: Can't assign requested address                          

and the lib/network

./network.t
117
cannot bind socket for 127.0.0.1,11119: Can't assign requested address
cannot create or bind socket: Can't assign requested address    

Any fixes for this?
-- 
Member - Liberal International	
This is doctor at nl2k.ab.ca	Ici doctor at nl2k.ab.ca
God, Queen and country! Beware Anti-Christ rising!  
USA petition for dissolution of your nation!

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.



More information about the inn-workers mailing list