[Kea-users] Client connectivity problem

Toby Walsh walshtj at gmail.com
Fri Nov 11 13:14:54 UTC 2016


This might not be a Kea problem, but switching my DHCP server to Kea
triggers it every single time. I have a small home network I'm
configuring. Topology looks like this:

ESXi Ubuntu VM with various services <- ESXi pfSense VM -> Unifi
switch -> Unifi AP -> Android phone

I started with pfSense's DHCP and each time I switch to it the network
works. I'm using Freeradius authentication on the Ubuntu VM and it
authenticates and there are no problems. When I switch off pfSense's
DHCP and switch on Kea with a host reservations (either in the conf
file or in mysql) the phone's wifi get's "connected, no internet" and
there is no connectivity (duh).

I've tried specifying the routers option and the dns option in the
kea.conf. The dns I'm using google's 8.8.8.8 and 8.8.4.4 for testing
purposes. I did have bind running initially but eliminated that to
reduce variables. One thing of note is the routers option in kea.conf
seems to be overwritten. I'm (currently) setting:

"subnet4": [
// ...
"option-data": [
{
  "name": "routers",
  "code": 3,
  "space": "dhcp4",
  "csv-format": true,
  "data": "pfSense's_ip_address"
},
// ...

But per dhcpdump it's getting Ubuntu's IP, which is also the IP
populated in the code 54 server field. Maybe this is confusing the
phone, because when I run tcpdump on any of the hardware in the
topology chain there is traffic associated with the MAC of the phone
and it's even trying to look up google servers and
connectivitycheck.gstatic.com at times but it gets stuck and lost
within my subnet.

My firewall rules are wide open so it's not getting blocked there, and
indeed the firewall logs nothing from the IP I'm assigning.

So the only difference from my perspective is: pfSense's DHCP works
for my subnet, Kea's doesn't. What else am I missing?

Thanks,
Toby


More information about the Kea-users mailing list