[Kea-users] Client connectivity problem

Toby Walsh walshtj at gmail.com
Sat Nov 12 03:13:56 UTC 2016


I have isolated this to something wrong with my database connection. I
have strictly followed the instructions from "Tips about Host
Reservations in Kea 1.1". I have a hosts table and a dhcp4_options
table configured correctly. When I restart the kea-dhcp4 server the
logs tell me the server is started correctly. I now have Kea set up to
run under systemctl and those logs tell me that on restarting the
server the lease database and the hosts database are opened. The lease
database is correctly populated by Kea upon obtaining a lease. But the
hosts database is not read and therefore neither is the dhcp4_options
database, and dhcpdump shows requests by the test devices for an IP
address but nothing happening and certainly Kea is quiet.

On the other hand, if I specify the reservations manually in the
kea.conf file using basic "hw-address" and "ip-address" fields both
test devices I'm using successfully obtain an IP address.

So what is different about the hosts table that I'm getting wrong? I
have the same database name/user name/password that I use to manually
populate/edit the tables. In the hosts table I'm populating:

host_id
dhcp_identifier (using UNHEX(REPLACE ... )
dhcp_identifier_type (using 'hw-address' mapping)
dhcp4_subnet_id
ipv4_address (using INET_ATON(@my_desired_ip))
hostname

and that's it. No next_server, no dhcp4_server_hostname, no
dhcp4_boot_file_name but I don't have those in the working kea.conf
reservation either.

In the dhcp4_options table I just have routers and DNS settings. I
tried using option 5 and 6 for DNS but it seems irrelevant since the
hosts table doesn't appear to be read anyway.

Nothing else seems to stick out to me so any tips on getting
mysql-backed Kea working would be great.

Thanks.

On 11 November 2016 at 21:14, Toby Walsh <walshtj at gmail.com> wrote:
> This might not be a Kea problem, but switching my DHCP server to Kea
> triggers it every single time. I have a small home network I'm
> configuring. Topology looks like this:
>
> ESXi Ubuntu VM with various services <- ESXi pfSense VM -> Unifi
> switch -> Unifi AP -> Android phone
>
> I started with pfSense's DHCP and each time I switch to it the network
> works. I'm using Freeradius authentication on the Ubuntu VM and it
> authenticates and there are no problems. When I switch off pfSense's
> DHCP and switch on Kea with a host reservations (either in the conf
> file or in mysql) the phone's wifi get's "connected, no internet" and
> there is no connectivity (duh).
>
> I've tried specifying the routers option and the dns option in the
> kea.conf. The dns I'm using google's 8.8.8.8 and 8.8.4.4 for testing
> purposes. I did have bind running initially but eliminated that to
> reduce variables. One thing of note is the routers option in kea.conf
> seems to be overwritten. I'm (currently) setting:
>
> "subnet4": [
> // ...
> "option-data": [
> {
>   "name": "routers",
>   "code": 3,
>   "space": "dhcp4",
>   "csv-format": true,
>   "data": "pfSense's_ip_address"
> },
> // ...
>
> But per dhcpdump it's getting Ubuntu's IP, which is also the IP
> populated in the code 54 server field. Maybe this is confusing the
> phone, because when I run tcpdump on any of the hardware in the
> topology chain there is traffic associated with the MAC of the phone
> and it's even trying to look up google servers and
> connectivitycheck.gstatic.com at times but it gets stuck and lost
> within my subnet.
>
> My firewall rules are wide open so it's not getting blocked there, and
> indeed the firewall logs nothing from the IP I'm assigning.
>
> So the only difference from my perspective is: pfSense's DHCP works
> for my subnet, Kea's doesn't. What else am I missing?
>
> Thanks,
> Toby


More information about the Kea-users mailing list