[Kea-users] timers defined on gloval scope are not exported with the get-config command

itay cohen icohen9987 at gmail.com
Wed Oct 4 04:25:45 UTC 2017


hi
my concern is that some parameters are configured in the config file, and
when i'm pulling the configuration via api the parameters are not there,

thank you for your replay

itay



On Tue, Oct 3, 2017 at 8:26 PM, Francis Dupont <fdupont at isc.org> wrote:

> itay cohen writes:
> > i have this configuration on the global scope
> >         "renew-timer": 900,
> >         "rebind-timer": 1800,
> >         "valid-lifetime": 3600,
> > it is used as the "default" timers, unless a timer is configured on the
> > subnet level.
> >
> > when i use the get-config command i cant see the timers configured on the
> > global level.
>
> => I have a question which is in fact the response: is your concern
> the fact you can't see these timers at the global scope, or the fact
> there are some subnets where no specific timer values are configured
> and a default value copied from the global scope is not configured?
>
> Regards
>
> Francis Dupont <fdupont at isc.org>
>
> PS: if the action of deriveParams (src/lib/cc/simple_parser.h) is
> misleading
> we have somewhere the code of a factorParams doing the opposite.
> It was considered as too complex and potentially even more misleading
> (i.e. clearly against the least astonishment principle) so was not adopted.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20171004/7d4d6f8a/attachment.html>


More information about the Kea-users mailing list