[Kea-users] DHCPv6 vendor-specific options

Laurent Aubert (laaubert) laaubert at cisco.com
Fri Jul 19 14:40:06 UTC 2019


Hi Marcin,



Unfortunately it didn't work:



msgtype=7(REPLY), transid=0xad82a7

type=00001, len=00012: 00:03:00:1b:00:17:3b:07:00:41:00:2c

type=00002, len=00014: 00:01:00:01:24:ba:4e:2e:02:fe:4a:73:d2:48

type=00003(IA_NA), len=00040: iaid=0, t1=60, t2=120,

options:

  type=00005(IAADDR), len=00024: address=2001:db8:beef::2, preferred-lft=2592000, valid-lft=2592000

type=00014, len=00000:

type=00017, len=00004: 26484 (uint32)

type=00025(IA_PD), len=00056: iaid=0, t1=0, t2=0,

options:

  type=00013, len=00040: NoPrefixAvail(6) "Sorry, no prefixes could be allocated."

1 relay(s):

relay[0]: msg-type=13(RELAY_REPLY), hop-count=0,

link-address=2001:db8:beef::, peer-address=fe80::217:3b07:41:2c, 1 option(s)

type=00018, len=00004: 00:00:00:16







# Option 17 definition for CG-Mesh

  "option-def": [

    {

            "name": "FND",

            "code": 1,

            "space": "vendor-26484",

            "type": "ipv6-address",

            "record-types": "",

            "array": false,

            "encapsulate": ""

    }

  ],



  "option-data": [

    {

          "name": "vendor-opts",

             "data": "26484"

    },

    {

             "name": "FND",

             "code": 1,

             "space": "vendor-26484",

             "data": "fd05::4:d"

    }

  ],



Is there anything else I could try ? My last resort plan is to switch back to ISC.



Thanks for your help

Laurent.



On 2019-07-19, 3:45 PM, "Marcin Siodelski" <marcin at isc.org> wrote:



    Hi Laurent,



    Thank you for reporting this issue. It looks like you discovered a bug

    in our documentation. We're going to improve our tests in this area to

    verify that the server behaves as expected.



    Meanwhile, can you please check whether replacing the

    "vendor-opts-space" with the "vendor-26484" in the option definition and

    option data section would make any difference for you?



    Kind Regards,



    Marcin Siodelski

    Sr. Software Engineer

    ISC



    On 19/07/2019 14:06, Laurent Aubert (laaubert) wrote:

    > HI,

    >

    >

    >

    > I’m struggling to configure my DHCP server to send a specific vendor

    > option. My config is the following:

    >

    >

    >

    >

    >

    > # Option 17 definition for CG-Mesh

    >

    >   "option-def": [

    >

    >     {

    >

    >             "name": "FND",

    >

    >             "code": 1,

    >

    >             "space": "vendor-opts-space",

    >

    >             "type": "ipv6-address",

    >

    >             "array": false,

    >

    >             "encapsulate": ""

    >

    >     }

    >

    >   ],

    >

    >

    >

    >   "option-data": [

    >

    >     {

    >

    >              "name": "vendor-opts",

    >

    >              "data": "26484"

    >

    >     },

    >

    >     {

    >

    >              "name": "FND",

    >

    >              "space": "vendor-opts-space",

    >

    >              "data": "fd05::4:d"

    >

    >     }

    >

    >   ],

    >

    >

    >

    >

    >

    > Below is what the server is replying to the client with only the

    > enterprise-id is in option 17. There is no Data:

    >

    >

    >

    > msgtype=7(REPLY), transid=0x6fc166

    >

    > type=00001, len=00012: 00:03:00:1b:00:17:3b:07:00:41:00:2c

    >

    > type=00002, len=00014: 00:01:00:01:24:ba:4e:2e:02:fe:4a:73:d2:48

    >

    > type=00003(IA_NA), len=00040: iaid=0, t1=60, t2=120,

    >

    > options:

    >

    >   type=00005(IAADDR), len=00024: address=2001:db8:beef::2,

    > preferred-lft=2592000, valid-lft=2592000

    >

    > type=00014, len=00000:

    >

    > *type=00017, len=00004: 26484 (uint32)*

    >

    > type=00025(IA_PD), len=00056: iaid=0, t1=0, t2=0,

    >

    > options:

    >

    >   type=00013, len=00040: NoPrefixAvail(6) "Sorry, no prefixes could be

    > allocated."

    >

    > 1 relay(s):

    >

    > relay[0]: msg-type=13(RELAY_REPLY), hop-count=0,

    >

    > link-address=2001:db8:beef::, peer-address=fe80::217:3b07:41:2c, 1 option(s)

    >

    > type=00018, len=00004: 00:00:00:16

    >

    >

    >

    >

    >

    > What am I missing ? I read the user guide a hundred times and my config

    > looks the same.

    >

    >

    >

    > Any help would be really appreciated !! I’m pulling my hair off on that

    > one !!

    >

    >

    >

    > Thanks,

    >

    > Laurent.

    >

    >

    > _______________________________________________

    > Kea-users mailing list

    > Kea-users at lists.isc.org

    > https://lists.isc.org/mailman/listinfo/kea-users

    >




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20190719/3eeb10bf/attachment-0001.html>


More information about the Kea-users mailing list