Bind9 and LDAP returns incorrect result

Luke luke at
Sun Jan 23 05:24:40 UTC 2005

I am having a problem with Bind9 and the bind-sdb LDAP patch.  The server
occasionally returns the incorrect address to a DNS query.  The incorrect
address that is returned is usually the IP address of one of the
authoritative DNS servers.

Here is what I am running:

Bind 9.3.0 (I have also tried 9.2.4)

Bind-sdb version 1.0

OpenLDAP 2.0.27 (I set bind-sdb to use LDAP version 2)

Sun 420R running Solaris 9 (sparc)

I have also tried older versions of Bind and bind-sdb.  I have two systems
that are having the problem.

I have four other name servers in a different location, they are Sun V100's
running Solaris 8 (sparc).  I have not had any problems at all with them.  I
have even copied over the installation of Bind from those systems to the
systems that I am having a problem with, and they continue to fail.

Has anyone see anything like this?  Any ideas on what I could look at to try
to diagnose this further.

Thanks a lot,


More information about the bind-users mailing list