pop email issue

Steve Ingraham singraham at okcca.net
Wed Nov 29 17:07:59 UTC 2006

Thank you for your reply.  Yes I have had this problem for some time and
I have asked about it in the past on this mail list.  I have still not
been able to resolve this problem.  I would like to mention that I did
not set this network up.  I have been attempting to understand how and
why it was setup the way it was since I started working on it.  This has
caused a great deal of confusion.

>Does Exchange 2003 where the mailbox is, face the public Internet?  If 
>not, your phone will need some sort of route into your private network 
>space (such as VPN.)

At present Exchange 2003 does not face the public Internet.  The
Exchange 2003 box has two nic cards but only one is connected internally
with a private IP.

You mention that the Exchange 2003 is the machine the phone needs to be
connecting to.  The email account was switched over to that machine from
the Exchange 2000 machine and did work prior to this switch.  So, to ask
a simple question, why did the email transfer to the phone when it was
connected to the Exchange 2000 box when the incoming mail setting was
set at "mail.okcca.net"?

>Try browsing to 
>www.whatismyip.com on your phone to see what IP address it has been 
>given - whether it's assigned by your own network or the mobile

The IP address for the phone is  It was not assigned by
our network.

>Does your qmailtoaster machine run a POP3 service?  If so, a firewall
>router is blocking external access to port 110.

It has some services for pop3 available but I don't believe they are
running on it.

I started this reply first thing this morning but have never sent it so
I am adding this last bit to the end of what I had been previously
composing.  I have been working on this problem all morning and thanks
to your post and a lot of searching through my network configuration I
believe I understand what has happened.  The mailbox was moved from the
Exchange 2000 box that had a public IP and a private IP to the new
Exchange 2003 box that only has a private IP.  Since the mailbox was
moved it was being directed to mail.okcca.net ( that did
not allow access through port 110.  In turn the address
no longer housed the mailbox and so when I attempted to direct to that
address an error occurred as well.  With the case being that the
Exchange 2003 box does not have a public IP I need to either move the
mailbox back to the 2000 box or set up the 2003 box with a public IP
address and then direct the phone to that IP.

I want to thank you for replying (again) to my questions concerning
this.  My appoligies for asking novice questions that perhaps do not
directly relate to BIND issues.  I believe you guys know a great deal
that help novices like me in our understanding of the relationship
between DNS, email, network configurations and how they all interact
together.  Please forgive my novice ways as I continue to ask for your
guidance on figuring out problems as they crop up.  As a novice
administrator I learn a great deal everytime I read posts on this list.



I believe I'm right in saying you've had this problem for a while now; I

seem to remember talking to you a while back.
Telnetting to mail.okcca.net externally (from my server 
port 25 (SMTP) works fine:

telnet mail.okcca.net 25
Connected to mail.okcca.net.
Escape character is '^]'.
220 Welcome to Qmail Toaster Ver. 1.3 smtp Server ESMTP

However, you cannot connect to the POP3 port on this server:

telnet mail.okcca.net 110
telnet: connect to address No route to host

This is the error usually seen when a firewall either on that box itself

or an intermediate router blocks the port.
Now, internally this may be a different story.

However, judging by what you're saying (the e-mail account in question 
resides on your Exchange 2003 server) - you need to be connecting to 
that machine, not mail.okcca.net.
The IP address of your Exchange 2003 is a private LAN address - that is,

not publicly accessible/routeable from the Net, therefore your phone 
will probably need some kind of VPN into your own network to get to that

server (whereas if your laptop is already on your internal network, this

won't be a problem.)

I think you need to clarify where your machines sit in relation to your 
private and public-facing networks, and how your phone connects (i.e. 
what IP address it gets assigned and where from.)  Try browsing to 
www.whatismyip.com on your phone to see what IP address it has been 
given - whether it's assigned by your own network or the mobile provider


Steve Ingraham wrote:
> For some details, I have a RedHat AS 3 box running Bind 9.2.4 with 
> qmailtoaster as a gateway for email.  This server then sends incoming 
> email to two Microsoft Exchange servers where the user mailboxes 
> reside. The first server runs Microsoft Server 2000 with Exchange 
> Server 2000. This server is the master exchange box with an external 
> IP address of  The other Exchange server is running 
> Exchange 2003 on a Windows Server 2003 system and is where this email 
> account in question resides.  The IP address for this server is 
>  I also have an internal DNS server on a Windows 
> Server 2003 computer (IP
Does Exchange 2003 where the mailbox is, face the public Internet?  If 
not, your phone will need some sort of route into your private network 
space (such as VPN.)
> The phone is configured with port 110 setup for the incoming emails at

> mail.okcca.net.  I have tried numerous configurations to get this 
> phone to receive emails again with no luck.  I have verified that the 
> pop3 configuration is functioning on the server by setting up a laptop

> running Windows XP with Outlook Express.  I configured OE to connect 
> to pop3 using the mail.okcca.net settings.  It connects with no 
> problem and I am able to send and receive emails from that computer.  
> My thoughts were that if this laptop can connect to the server using 
> pop3 configuration just like the Trio 650 phone everything should 
> work.  Pop email works on the laptop but not on the phone.  The phone 
> has service through Cingular.  I have talked with cingular support on 
> the phone and they believe there is a configuration problem on the 
> server.
Does your qmailtoaster machine run a POP3 service?  If so, a firewall or

router is blocking external access to port 110.


Andy Shellam
NetServe Support Team

the Mail Network
"an alternative in a standardised world"

p: +44 (0) 121 288 0832/0839
m: +44 (0) 7818 000834

More information about the bind-users mailing list