Debian vs SuSE

Bill.Light at Bill.Light at
Tue Sep 11 23:13:48 UTC 2007

In /etc/bind/named.conf.local, I added the following line after the line 
// include "/etc/bind/zones.rfc1918";
include "/etc/bind/";

I then used the SuSE convention I was shown of and 
copied to (also in /etc/bind/  directory) which 
looks like:

$TTL    86400       IN      SOA     dns1 (
                        webmaster       ; Who to notify at 
                        2003060101      ; Serial
                        7200            ; Refresh after 2 hours
                        3600            ; Retry after 1 hour
                        604800          ; Expire after 1 week
                        7200 )          ; Negative Cache TTL of 2 hours
; Name servers
                        IN      NS
                        IN      NS
                        IN      NS
; Mail servers
                        IN      MX      10  ; 
;mail                   IN      A     
; Host addresses
localhost               IN      A     
dns1                    IN      A     
mail                    IN      A     
; Aliases
www                     IN      CNAME 
; SPF Record setup - see: http:///
;       IN      TXT     "v=spf1 a ip4:, ~all"

I thought I was being failry vanilla, but I'm still getting lost as to 
where files are in Debian vs SuSE.  I am a total Debian noob.

SuSE Bind is 9.2.4  (as I recall it is an old 9.0 or 9.1 SuSE distro)
and the Bind on debian is 9.3.4



Karl Auer <kauer at> 
Sent by: bind-users-bounce at
09/11/07 03:52 PM

comp-protocols-dns-bind at

Re: Debian vs SuSE

On Tue, 2007-09-11 at 15:04 -0700, Bill.Light at wrote:
> I am moving a working BIND from a SuSE box to a Debian (Etch) box.  I've 

> tried scp, copy/paste and  touching a new file, typing from scratch ... 
> all with the same result.
> When I rndc reload or start, I start off with a string of errors
> unknown option '$TTL'
> unknown option 'Who'
> unknown option 'Serial'
> I've tried starting with a comment (semi-colon) and it eliminates all 
> those errors, and then gives   syntax error near ';'

It sounds a bit as if you are not loading the file you think you are
loading. "Unknown option" doesn't usually come from a zone file, but
from a config file - but $TTL is in a zone file, not a config file.

Are the BIND versions the same? How about posting the actual fragment
that gives the error?

Regards, K.

Karl Auer (kauer at                   +61-2-64957160 (h)                  +61-428-957160 (mob)

More information about the bind-users mailing list