BIND 9.10 compilation problem for FreeBSD 6.x/7.x

Shawn Zhou shawnzhou00 at
Tue May 6 14:53:52 UTC 2014

Thanks for explanation and solution!
I just tested the change and worked fine.
On Tuesday, May 6, 2014 7:32 AM, Tony Finch <dot at> wrote:
Shawn Zhou <shawnzhou00 at> wrote:
>> Any problem has problem building BIND 9.10 for FreeBSD? We are using the
>> same process that worked for building 9.9.4 to build 9.10 on FreeBSD
>> 6.x/7.x but we are getting "ld: invalid BFD target" error.
>Yes. BIND's linking stage changed between 9.9 and 9.10 so instead of
>invoking cc to link, its build scripts now invoke ld directly. If you used
>to use -Wl to escape linker flags you must now pass them unescaped.
>My build used to have
>    export LDFLAGS="-Wl,-R/opt/OpenSSL/lib"
>but now has
>    export LDFLAGS="-R/opt/OpenSSL/lib"
>f.anthony.n.finch  <dot at dotat.at
>Southwest Forties, Cromarty, Forth, Tyne, Northwest Dogger: Southerly or
>southwesterly 4 or 5. Slight or moderate. Showers. Good, occasionally
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the bind-users mailing list