dhcpserver and dhcperf on same machine - still not working

Rajitha Chinnapu rajithachinnapu at yahoo.com
Thu Aug 12 17:52:32 UTC 2010

Thanks Marc.

Here is what my dhcpd.conf looks like:

# DHCP Server Configuration file.
ddns-update-style interim;
ddns-updates off;

# Subnet
subnet netmask {
        option routers        ;
        option subnet-mask    ;
        option broadcast-address;
        option domain-name              "test.com";
        option domain-name-servers;
        option ntp-servers    ;
        option interface-mtu            1400;
        range                 ;
        default-lease-time              5184000;
        max-lease-time                  5184000;

now, dhcpd is running on port 67.  the manual from nominum for dhcperf quotes 
the following:

     -p, --port port
     Sets the UDP port upon which dhcperf sends and receives DHCP messages.
     The default is 67—dhcperf emulates a DHCP relay agent and uses the “DHCP 

1. from the above, it looks like dhcperf also runs on port 67.  how can that 

2. if i have to run the dhcperf on the same machine as dhcpd, what port do i use 
for the client? 

3. i tried dhcperf on port 68, but still, i get the same response... more over, 
--progress option wont give any more debug than what there is already. so, i 
cannot provide any more logs than whats below...

sudo ./dhcperf --server --one-discover --progress -p 68
No response after 4 seconds: failed to acquire address.

4. is there any way to make dhcperf log more information?
5. i am running the dhcperf on teh same machine as dhcpd just to see how dhcperf 
works. the actual test is to run dhcperf on a different subnet from that of 


From: Marc Perea <marccp at srttel.com>
To: dhcp-users at lists.isc.org
Sent: Thu, August 12, 2010 7:48:29 AM
Subject: Re: dhcpserver and dhcperf on same machine - still not working

Hi Rajitha,
It's a good step to install dhcperf on the same host as the dhcp daemon runs on 
- that indicates to me that your DHCP server doesn't want to give addresses to 
random clients perhaps? Our DHCP server only responds to known hosts, so when I 
want to run dhcperf I have to add another network, define a class of hosts to 
test with (so that they'd be known), and allow the class within the range for 
load testing (implicitly denying the rest of my known clients). The config looks 
something like this:
class "loadtest" { match if (option agent.remote-id = 6d:61:72:63:63:70); }

        subnet netmask { #LOAD TEST
                option routers;
                option subnet-mask;
                option broadcast-address;
                pool { authoritative; range; allow 
members of "loadtest";}

you could also make a host entry (by mac or other identifier) to match with 
instead of using a class, if that's easier.
This is based on the assumption that your DHCP server is somewhat locked down to 
the clients that it supports - if that's not the case, what are you seeing in 
the logs when you attempt the dhcperf?
dhcperf should work against any DHCP server - it simply pretends to be many 
dozens/hundreds/thousands of clients coming from a certain network segment - it 
just so happens that all that happens as emulation from a single host.
>And then, to account for the drawback in the following post in the groups, i 
>installed dhcperf on the same machine that has the dhcp server. but still, it 
>gives the same problem. That means, something else is wrong here. any help is 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/dhcp-users/attachments/20100812/d9cca323/attachment.html>

More information about the dhcp-users mailing list