Odd bug in setting up a new server

Russ Allbery rra at stanford.edu
Tue Dec 19 08:42:59 UTC 2000


I'm finally setting up a new reading server (sorry I haven't had much time
to spend on INN lately... hopefully this will get better), and I'm trying
to move most of an existing spool to the new server.  Which ended up being
very interesting, since some of the articles had been moved around between
servers since the 1.4 days and didn't have Xref headers, so I got to do
all sorts of fun hacky shell scripts to do the one-time fix....

But anyway, I've been doing a lot of setting up a server, feeding it some
stuff, tearing it down, wiping the spool, active file, history, and
overview, and starting again as I experiment with stuff.  And at one
point, while doing that, some articles ended up stored in a cycbuff (most
of my spool is tradspool).  Next time I wiped everything (except the
cycbuffs) and tried to start innd, it hung hard when initializing the
storage manager.  Zeroing the cycbuffs and restarting it fixed it.

Weird.  I'm not sure what it was doing.  truss didn't return anything, so
whatever it was doing, it wasn't making any system calls doing it.  It was
acting like it was in a tight infinite loop over something.

Anyway, I don't have time to try to recompile with debugging and track it
down right now, so I thought I'd drop this message in in case someone else
does down the road.

-- 
Russ Allbery (rra at stanford.edu)             <http://www.eyrie.org/~eagle/>



More information about the inn-workers mailing list