INN won't start

Kelly F. Hickel kfh at mqsoftware.com
Thu Jul 12 18:27:11 UTC 2001


Well, I tracked it down (I know I've been a bit verbose on this one, but it
was a bit perplexing).

If you try to add a top level group (no '.'s) then things go a bit berserk,
innd dies, and someone writes a record full of nulls to your active file.

This is somewhat less than desirable...

-Kelly

-----Original Message-----
From: Kelly F. Hickel 
Sent: Thursday, July 12, 2001 1:20 PM
To: Kelly F. Hickel; 'Ron Jarrell'; 'inn-workers at isc.org'
Subject: RE: INN won't start


OK, I move an old version of active in, and now it starts.  The problem
seems to have started when I was trying to create a new, local newsgroup.

I do a "ctlinnd newgroup mqsoftware", trying to create a local only group,
and the command just hangs.  After that (once I kill things and try again)
I'm back in the state I was in where innd wouldn't start.

Is there somewhere I can read up on how to create local only newsgroups?  I
must be doing something wrong.  I want to create groups like:
company
company.topic1
company.topic2
etc.

Any help?
-Kelly

-----Original Message-----
From: Kelly F. Hickel 
Sent: Thursday, July 12, 2001 1:14 PM
To: Kelly F. Hickel; 'Ron Jarrell'; 'inn-workers at isc.org'
Subject: RE: INN won't start


I reran inncheck and it complained about line 7, so I deleted that line (it
was for a group my upstream provider doesn't carry anyway), and tried again.

Now I'm just getting the one error line:
Jul 12 13:10:40 reddwarf innd: SERVER bad_active ...

I really wish there was a way to make innd give me better info about what
the problem is....

-Kelly

-----Original Message-----
From: Kelly F. Hickel 
Sent: Thursday, July 12, 2001 1:07 PM
To: 'Ron Jarrell'; Kelly F. Hickel; inn-workers at isc.org
Subject: RE: INN won't start


Nope, I didn't mangle it, that's how it appears in the file.
I've tried starting it using inndstart (which IS suid) and by running innd
directly.  I've also run inncheck, with no errors.
I'll scan the active file and see what I can find.
-Kelly

-----Original Message-----
From: Ron Jarrell [mailto:jarrell at solaris.cc.vt.edu]
Sent: Thursday, July 12, 2001 12:40 PM
To: Kelly F. Hickel; inn-workers at isc.org
Subject: Re: INN won't start


At 10:14 AM 7/12/01 -0500, Kelly F. Hickel wrote:

>I made a small change to newsfeeds, and now innd won't start (even after I
>undid the change).
>
>news.crit output follows:
>Jul 12 10:10:42 reddwarf innd: SERVER cant bind RCreader Permission denied
>Jul 12 10:11:48 reddwarf innd: SERVER bad_active ...
>Jul 12 10:12:42 reddwarf innd: SERVER bad_active ...

It's your active file.  That's why it's saying "bad_active".  The rest of
the line, where you
substituted the "..." would actually explain *what* was bad about the active
file.  Presumably
you, or something, mangled it somehow.


More information about the inn-workers mailing list