Possible Solaris 8/INN-2.3.2 Problem

Mark G. Thomas Mark at Misty.com
Tue Jun 12 00:45:11 UTC 2001



Hi,

I'm running 2.3.2 with db-3.2.9 under Solaris-8.  I had some initial trouble
with expireover core dumping on my fresh overview database, however once I
re-made the overview database a second time, I haven't had any other weirdness
in the past several weeks since the upgrade, other than the fact that today 
expire seems still to be running after 16 hours today, when normally 
it's done in a few hours.  I did not make any attempts at enabling large 
file support

 ./configure  --prefix=/var/news --with-berkeleydb=/opt/db-3.2.9 --with-perl --with-sendmail=/usr/lib/sendmail --with-tmp-path=/var/news/tmp --with-openssl=/opt/openssl-0.9.6a

Feel free to email me off-list to compare notes.

Mark Thomas (Mark at Misty.com)


On Mon, Jun 11, 2001 at 05:16:58PM -0700, Timothy Demarest wrote:
> 
> >>>>> "Alex" == Alex Kiernan <alexk at demon.net>
> >>>>> wrote the following on 29 May 2001 13:11:26 +0100
> 
> 
>   >> I even tried recompiling everything under Solaris 2.5.1, but that
>   >> hasn't helped. If there doesn't seem to be a fix for 2.3.2, I'll
>   >> probably go back to 2.3.0 which works on my Solaris 8 box. In this
>   >> case, what do I need to do to recreated my ovdb and history files from
>   >> the articles that are in my spool? The history* and ovdb files
>   >> currently are probably damaged pretty badly - what ovdb files can I
>   >> delete before recreting them?
>   >> 
> 
>   Alex> Same version of Berkeley DB or different?
> 
> 
> OK. There is definitely something really broken with my 2.3.2 under Solaris
> 8. I recompiled eveything for Solaris 8 with the following options:
> 
> env LDFLAGS="-R /opt/local/lib -R /opt/local/gnu/lib" ./configure 
> --with-sendmai
> l=/usr/lib/sendmail --with-largefiles --with-run-dir=/var/run/news 
> --with-spool-
> dir=/var/spool/news --with-log-dir=/var/log/news --with-tmp-path=/var/spool/new
> s
> /tmp --with-perl --with-berkeleydb=/opt/local
> 
> Berkeley DB is v3.2.9.
> 
> After recompiling installing, I decided to completely wipe out the overview
> database files, the history file, and history indexes. I recreated both
> from the existing spool with makehistory and makedbz, which worked fine. I
> started news using rc.news, which worked just fine. However, all is not
> well. The innd daemon is running, but I'm back to my same old issues: it's
> stuck in LWP mutex lock loops. No errors to the various log files -- it's
> running, but not really doing anything.
> 
> It's been a few weeks - has any other Solaris 8 site had similar problems
> with 2.3.2 and Berkeley DB 3.x?
> 
> Tim
> 
> 
> --
> Timothy Demarest                      ArrayComm, Inc.  
> demarest at arraycomm.com                2480 North 1st Street, Suite 200
> http://www.arraycomm.com              San Jose, CA 95131
> 
> 

-- 
Mark G. Thomas (Mark at Misty.com -- http://www.misty.com/)


More information about the inn-workers mailing list