pamckpasswd

Graeme Mathieson graeme+inn-workers at mathie.cx
Tue Jan 8 18:50:53 UTC 2002


On Mon, Dec 31, 2001 at 12:45:34AM +0900, Katsuhiro Kondou wrote:
> 
> I'm wondering if both are included into CURRENT.

That would be great, yes.

> It looks, at least to me, attached is enough to
> support PAM support.

It should be enough for most folks.  pass_conv() still leaks memory, so
it would need to be fixed up if the interface between nnrpd and the
password helper became persistent.  There's no easy way it can do PAM
session management either, but I can't see anybody wanting that
anyway...

The very same diff patches cleanly against STABLE apart from
authprogs/Makefile where the change is pretty obvious.  I don't know
if you plan to have another 2.3.x release though...
-- 
graeme+sig at mathie.cx                          http://www.mathie.cx/~graeme/


More information about the inn-workers mailing list