ovdb.c warning with INN 2.3.3 and BerkeleyDB

Antoine Delvaux antoine.delvaux at belnet.be
Fri May 31 09:53:34 UTC 2002


Hello,

When trying to compile INN 2.3.3 with BerkeleyDB 3.3.11 we've got the 
following warning :

gcc -g -O2 -I../include   -I../../include -I.. 
-I/usr/local/BerkeleyDB.3.3//include -c ovdb.c -o ovdb.o
ovdb.c: In function `ovdb_open_berkeleydb':
ovdb.c:697: warning: passing arg 2 of pointer to function from 
incompatible pointer type

Nevertheless, INN compile fine.  But as we are having trouble with INN 
crashing very often and leaving the overview DB not in a clean state, we 
were wondering if this warning could indeed be a problem.

Anybody knows more about this ?

Antoine.


-- 
http://www.belnet.be                              Tel: + 32 2 790 33 33
BELNET Service Support Team                       Fax: + 32 2 790 33 34


More information about the inn-workers mailing list