2.3.5 w/db 4.1.25

Ron Jarrell jarrell at solaris.cc.vt.edu
Thu Feb 20 11:47:42 UTC 2003


At 05:00 AM 2/20/03 -0500, Ron Jarrell wrote:
>At 11:22 AM 2/17/03 +0000, Alex Kiernan wrote:
>>Russ Allbery <rra at stanford.edu> writes:
>>
>>> Ron Jarrell <jarrell at solaris.cc.vt.edu> writes:
>>> > At 04:10 PM 2/14/03 -0500, you wrote:
>>> 
>>> >> Ok, so, I had my head stuck in the world of mail servers for a while,
>>> >> and have been somewhat ignoring inn... Now I'm trying to catch up.
>>> >> Running 20030213 current.  Now, based on the news file, it looks like
>>> >> it should be capable of
>>> 
>>> > Actually, I meant stable, not current... 
>>> 
>>> I think the NEWS file in STABLE may be wrong, and 4.x means 4.0.
>>
>>Correct. -STABLE has changes so the code compiles, but not so it
>>works.
>>
>>> Alex committed support for 4.1 to CURRENT; Alex, that didn't make it
>>> into STABLE, did it?
>>> 
>>
>>It didn't - I'm still trying to find time to test the fix for that I
>>put into -CURRENT :(
>
>
>Ok, I'm kinda chasing my tail here... Is 4.1 supposed to work in -CURRENT? 
>I've tried upgrading my test server to current.  Using ovdb_init -u failed miserably
>(with db-4.1), so I killed everything, blew away my overview files, and figured I'd
>use makehistory to rebuild it.  Looks like I need to do a ovdb_init now before
>running makehistory, because makehistory causes errors about ovdb_monitor.. So I
>start ovdb_init, which creates a bunch of files, but does *not* create the ovnnnnn files.
>
>I run makehistory, and makehistory now says that it cannot open overview, file exists.
>But what's showing up in *syslog* is DB handle previously used in transaction,
>missing transaction handle, and open: can't store numdbfiles: invalid argument...
>
>So how in hell do you rebuild the db now, or is both current and stable just plain broken?

In the "answering my own question" department: Yes, it's broken in both STABLE and CURRENT.
4.1 compiles but doesn't quite run in either.  4.0.14, however, does seem to work in CURRENT
at least.  Haven't gone and recompiled STABLE again.

System seems to work.  Although makehistory -b invalidated *every single* article in the system!




More information about the inn-workers mailing list