[Kea-users] Hosts refusing lease offers?

Joelson Vendramin jtvendramin at yahoo.com.br
Fri Feb 15 11:05:03 UTC 2019


Hi Klaus,
I remember a similar tricky situation. Some clients complaining about leases offers. 

Then I find a strange solution: configuring KEA to send "renew-timer" and "rebind-timer" optional parameters together with "valid-lifetime" (mandatory).
This way:  "valid-lifetime": X,
  "renew-timer": 50% * X,
  "rebind-timer": 87,5% * X,

Hope this clue helps you someway.
Regards,
--Joelson Vendramin 

    Em quinta-feira, 14 de fevereiro de 2019 22:36:38 BRST, Klaus Steden <klausfiend at gmail.com> escreveu:  
 
 
Hi there,
I've got a bit of a puzzler on my hands. We've racked some new gear and are preparing to provision it.
Scope definitions have been added to Kea, and are active.
Hosts are on the network, and are generating DHCP requests.
Kea is responding as expected and offering leases, but none of these machines (6 racks worth) are accepting the offers, leaving them stranded.
The hardware is Dell, so it's actually the iDRAC that's not leasing, but a different batch of similar hardware in other racks (installed two weeks ago) had no such issues.
We're reasonably confident that it's not something on the switches, but for the life of me I can't identify why these aren't accepting leases.
I've attached a sample of the debug output in the log (cranked up to 99) with only DNS info redacted.
Again, the most confusing thing here is that a comparable platform in the same data center in different racks had no issues, and the only change is additional DHCP scopes.
thanks,Klaus_______________________________________________
Kea-users mailing list
Kea-users at lists.isc.org
https://lists.isc.org/mailman/listinfo/kea-users
  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/kea-users/attachments/20190215/d5f2ef2c/attachment.html>


More information about the Kea-users mailing list