[stork-users] Stork agent install

Talkabout talk.about at gmx.de
Thu May 27 18:04:30 UTC 2021


Hi Craig,

I tried the same as you did (some months ago and some days ago) and 
faced the exact same issue. It seems that the dependencies, that rake is 
downloading, are only available for x86/x64 platform, not for arm. This 
is what I figured out looking at "Rakefile". Somebody with more 
knowledge needs to confirm this, but from what I have researched there 
is no way to get stork working with ARM at the moment.

Bye

------ Originalnachricht ------
Von: "Craig Dunn" <sendai789 at googlemail.com>
An: "Jesse McDermid" <jesse.mcdermid at mahaska.org>
Cc: stork-users at lists.isc.org
Gesendet: 27.05.2021 14:46:20
Betreff: Re: [stork-users] Stork agent install

>ok so I installed all the pre-reqs the site shows and running he agent 
>install I get the following error:
>
>pi at DHCP1:/usr/local/etc/stork $ sudo rake install_agent
>Stork build date: 2021-05-27 12:51 (timestamp: 210527125147)
>/usr/local/etc/stork/tools/1.15.5/go/bin/go get -d -u 
>github.com/golang/protobuf/protoc-gen-go
>/usr/local/etc/stork/tools/1.15.5/go/bin/go: 1: 
>/usr/local/etc/stork/tools/1.15.5/go/bin/go:ELF: not found
>/usr/local/etc/stork/tools/1.15.5/go/bin/go: 2: 
>/usr/local/etc/stork/tools/1.15.5/go/bin/go: @: not found
>/usr/local/etc/stork/tools/1.15.5/go/bin/go: 3: 
>/usr/local/etc/stork/tools/1.15.5/go/bin/go: Syntax error: "(" 
>unexpected
>rake aborted!
>Command failed with status (2): 
>[/usr/local/etc/stork/tools/1.15.5/go/bin/g...]
>/usr/local/etc/stork/Rakefile:254:in `block in <top (required)>'
>Tasks: TOP => install_agent => build_agent => 
>/usr/local/etc/stork/backend/api/agent.pb.go => 
>/root/go/bin/protoc-gen-go-v1.3.3
>(See full trace by running task with --trace)
>
>Google searches has shown little in the way of help, anyone have any 
>ideas?
>
>Thanks
>
>On Wed, 26 May 2021 at 22:50, Craig Dunn <sendai789 at googlemail.com> 
>wrote:
>>Thanks Jesse, I have Ubuntu 18.04  currently I'll check the link out 
>>and give it a try.
>>
>>On Wed, 26 May 2021, 22:40 Jesse McDermid, 
>><jesse.mcdermid at mahaska.org> wrote:
>>>It is possible. Building from source is covered here: 
>>>https://stork.readthedocs.io/en/v0.17.0/install.html#installing-from-sources 
>>><https://stork.readthedocs.io/en/v0.17.0/install.html#installing-from-sources>. 
>>>It has been a few releases since I did it last, but I think you will 
>>>find the experience least painful if you use Ubuntu 18. I tried using 
>>>CentOS 7 and gave up: too many prerequisites required versions that 
>>>were not standard to that release.
>>>
>>>
>>>
>>>-Jesse
>>>
>>>
>>>
>>>From: Stork-users <stork-users-bounces at lists.isc.org> On Behalf Of 
>>>Craig Dunn
>>>Sent: Monday, May 24, 2021 12:52 PM
>>>To:stork-users at lists.isc.org
>>>Subject: [stork-users] Stork agent install
>>>
>>>
>>>
>>>Hi all,
>>>
>>>
>>>
>>>I have been user Kea for DHCP for a while now, I experimented with 
>>>stork as well but my DHCP server is arm based so currently there is 
>>>no install candidate for the stork agent. I was wondering if I can 
>>>build from source? I searched the gitlab repo and cloudsmith but 
>>>there are no instructions or anything saying you can.
>>>
>>>
>>>
>>>Thanks guys
>>>
>>>--
>>>Stork-users mailing list
>>>Stork-users at lists.isc.org
>>>https://lists.isc.org/mailman/listinfo/stork-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.isc.org/pipermail/stork-users/attachments/20210527/9c361850/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: talk.about at gmx.de.asc
Type: application/pgp-keys
Size: 1669 bytes
Desc: not available
URL: <https://lists.isc.org/pipermail/stork-users/attachments/20210527/9c361850/attachment-0002.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 522 bytes
Desc: not available
URL: <https://lists.isc.org/pipermail/stork-users/attachments/20210527/9c361850/attachment-0003.bin>


More information about the Stork-users mailing list